Caffeine not working on Pop!_OS 17.10

Bug #1732569 reported by Jason McFarlane on 2017-11-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned

Bug Description

When I click the icon, nothing happens... no coffee cup tray icon that I see running Ubuntu on my older laptops. The laptop also goes into hibernation as usual after an attempted Caffeine launch.

When I try to run from terminal:

caffeine
/usr/bin/caffeine:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gtk, GLib

Probably relevant, when I update the repository:

sudo apt-get update
Hit:1 http://us.archive.ubuntu.com/ubuntu artful InRelease
Ign:2 http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu artful InRelease
Hit:3 http://security.ubuntu.com/ubuntu artful-security InRelease
Get:4 http://us.archive.ubuntu.com/ubuntu artful-updates InRelease [78.6 kB]
Hit:5 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu artful InRelease
Hit:6 http://us.archive.ubuntu.com/ubuntu artful-backports InRelease
Hit:7 http://ppa.launchpad.net/system76-dev/stable/ubuntu artful InRelease
Hit:8 http://ppa.launchpad.net/system76/pop/ubuntu artful InRelease
Err:9 http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu artful Release
  404 Not Found
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Reuben Thomas (rrt) wrote :

Caffeine is in Ubuntu now, so no need to use the PPA for recent Ubuntu versions, unless you are testing a newer version of Caffeine. As you can see, it's not built for artful in the PPA. Closing.

Changed in caffeine:
status: New → Invalid
Jason McFarlane (jmcfar) wrote :

Thanks. But exact same problem after uninstalling caffeine and installing from the shop. Nothing happens when I click on the 'caffeine' and 'caffeine indicator' app buttons. When attempting to open from terminal I still receive this message:

caffeine
/usr/bin/caffeine:25: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import GObject, Gtk, GLib

Not sure what to do to fix

Jason McFarlane (jmcfar) wrote :

Apparently others solved this problem by installing the PPA (I think that's why I did it in the first place) https://elementaryos.stackexchange.com/questions/10417/caffeine-how-to-work-it

Reuben Thomas (rrt) wrote :

Sorry, I'm not doing distro-specific support outside Ubuntu/Debian. Please take this up with your distro support, and if there's an underlying Caffeine bug, then do file one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers