Caffeine Crash

Bug #1728612 reported by Mina Morose on 2017-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned

Bug Description

I am using Fedora 26 and i installed it from python pip they says that the version i installed is fork of 2.4 but this only package that i could find for fedora i tried to use source but it's just gave me more error when i try to run the version that i installed from pip it gives me the error

The Command I used For install
--------------------------------
pip2 install caffeine-ng
--------------------------------

=================================================================================================
/usr/lib/python3.6/site-packages/caffeine/main.py:59: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3
INFO:caffeine.core:Caffeine is starting up...
Traceback (most recent call last):
  File "/usr/bin/caffeine", line 11, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/site-packages/caffeine/main.py", line 437, in main
    main = GUI(arguments["--preferences"])
  File "/usr/lib/python3.6/site-packages/caffeine/main.py", line 159, in __init__
    self.ProcAdd = ProcAdd()
  File "/usr/lib/python3.6/site-packages/caffeine/main.py", line 113, in __init__
    builder.add_from_file(get_glade_file("proc.glade"))
GLib.Error: gtk-builder-error-quark: /usr/lib/python3.6/site-packages/caffeine/../../../../share/caffeine/glade/proc.glade:33:37 Invalid property: GtkDialog.has_separator (11)
===========================================================================================
i suggest to make the program universal for all distribution through pip you programed a good program and you used good language that work on all distro >>>> it will be a good idea to distribute through pip officially and give it a good maintenance instead of launchpad and debian .

i tried the commands on setup.py like build_ext and building rpm pkg and all give me ressult but the build don'twork with a lots of error

Reuben Thomas (rrt) wrote :

If you want to use caffeine-ng, you'll need to report the bug to caffeine-ng, not here (this is the original Caffeine project).

If you want to use Caffeine, that's fine. There is currently no pip distribution of Caffeine, and I don't know anything about rpm packaging of Caffeine, only Debian packaging.

I'd be happy to have some help getting it on PyPI, but I don't use PyPI much myself, so it's not something I plan to spend time on.

Changed in caffeine:
status: New → Invalid
Changed in caffeine:
status: Invalid → Opinion
Reuben Thomas (rrt) wrote :

This bug report is for a build error for another package (caffeine-ng). Therefore, it is invalid.

Changed in caffeine:
status: Opinion → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers