Caffeine only works once

Bug #1412083 reported by ramsesra on 2015-01-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned
caffeine (Ubuntu)
Undecided
Unassigned

Bug Description

Hello . I have a problem with caffeine 2.8/2.8.1/2.8.2. And i think these is a bug of caffeine . When i first time turn on full screen video caffeine work well , but when i turn off full screen and repeated on the full screen video, caffeine does not work and system go to suspend/hibernate mode.Doesn't work.
Please correct a bug. Thankyou.
~ $ caffeine
<class 'Xlib.protocol.request.QueryExtension'>
$ caffeine -V
caffeine 2.8.2
~ $ caffeine -h
usage: caffeine [-h] [-V]
Prevent desktop idleness in full-screen mode

Tested on Linux Mint 17.1 Xfce x8_64 , Ubuntu 14.04.1 x86_64,
 Linux Mint 17.1 Cinnamon x86_64

ramsesra (ramsesra200) on 2015-01-18
Changed in caffeine:
status: New → Incomplete
status: Incomplete → New
ramsesra (ramsesra200) on 2015-01-18
description: updated
ramsesra (ramsesra200) on 2015-01-18
description: updated
ramsesra (ramsesra200) on 2015-01-18
description: updated
summary: - caffeine not work
+ Caffeine Doesn't work
Reuben Thomas (rrt) wrote :

I am looking into what may well be the same bug, or a related bug. What does "ps ax|grep caffeine" show when caffeine is not working?

summary: - Caffeine Doesn't work
+ Caffeine only works once
Reuben Thomas (rrt) wrote :

Caffeine 2.8.3 fixes this bug; apologies, it was a stupid mistake of mine.

Changed in caffeine:
status: New → Fix Released
ramsesra (ramsesra200) wrote :

Hi guys. I have updated caffeine to 2.8.3 version and i have remove and reinstall caffeine. But Work Only for prevent screensaver and system still go to hibernate/suspend. What happening.
Automatically does not work. Only from the icon tray to activate manual. Thus Caffeine works in version 2.4. ((

ramsesra (ramsesra200) wrote :

$ ps ax|grep caffeine
 1761 ? Sl 0:00 /usr/bin/python3 /usr/bin/caffeine
 4121 pts/1 S+ 0:00 grep --colour=auto caffeine

Benjamin J Norton (leomcsnarf) wrote :

$ ps ax|grep caffeine
 6576 ? Sl 0:00 /usr/bin/python /usr/bin/caffeine
 6968 pts/0 S+ 0:00 grep caffeine

Does not work for me either.... Ubuntu Trusty 14.04.1 AMD64

Caffeine does not work for me either, I am afraid - at least not so far as stopping the screensaver when using full-screen Skype goes. And I even had Caffeine manually set to 'activated'.

caffeine 2.8.3 on Linux Mint 17.1 x64.

EDIT to my above post: I am running Cinnamon (cf. bug report 1412174). I might add that I think that the version of Caffeine called 'Caffeine Plus' *does* work.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in caffeine (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) on 2016-04-29
affects: ubuntu → caffeine (Ubuntu)
Changed in caffeine (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers