Caffeine won't start. Worked perfectly fine up until 2.7 run caffeine from a terminal produces <class 'Xlib.protocol.request.QueryExtension'>

Bug #1320955 reported by David Shepherd on 2014-05-19
76
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Caffeine
Undecided
Unassigned

Bug Description

Caffeine terminal output <class 'Xlib.protocol.request.QueryExtension'>

Caffeine fails to autostart or start from terminal.

Giovanni Mellini (merlos) wrote :

Same for me with version 2.7 on 14.04. No icon is shown.
The process is alive

giovanni@casetta:~$ ps axf | grep caff
 6523 ? Sl 0:00 \_ /usr/bin/python3 /usr/bin/caffeine
 6617 pts/1 S+ 0:00 \_ grep --color=auto caff
giovanni@casetta:~$

Giovanni Mellini (merlos) wrote :

Just read 2.7 release announce
"This release removes the user interface and manual operation, and reduces resource consumption by not using external programs. Caffeine is now fully automatic: when the active window is full screen, Caffeine inhibits desktop idleness (and thereby disables the screen saver and/or screen sleep)."

So with 2.7 the gui is gone, we have only the background process.
I think that this bug is invalid

Eric Bartels (ebartels) wrote :

Bummer. It was nice to be able to control this manually. Sometimes you want this even if there isn't a fullscreen app runing, for instance, when reading. Does this mean caffeine can no longer be used for this case?

I agree with Eric, but I understand the reason why they took it out.

Would it be possible to give users the option to choose to have the user interface or not?
I'm not a programmer, so I have no idea if this is doable.

Changed in caffeine:
status: New → Confirmed
Reuben Thomas (rrt) wrote :

It's working fine, it just doesn't have a UI any more. The output about "Xlib" is a bug in python3-xlib which is already fixed upstream.

Changed in caffeine:
status: Confirmed → Won't Fix
status: Won't Fix → Invalid
Ed Guenter (edgue) wrote :

This new implementation might make sense for some people, it doesn't make sense for me at all.

There are occasions when I turn full screen ... just for myself. And when I then leave for lunch,
I goddam need the screen saver to kick in. And then there are occasions (for example when doing
screen shares with eclipse for code reviews) where I would like caffeine to turn off the screensaver;
but there is nothing full screenish around.

Sorry folks, but if you really think that resource consumption is an issue - then give the user a CHOICE.
I do not care about resources, I SO MUCH LOVED the little caffeine icon that I could manually control.

Without this icon, you rendered caffeine completely useless for me (and probably other folks as well).

PLEASE CONSIDER UNDOING; OR AT LEAST GIVE YOUR USERS A CHOICE!

Kees Vlek (ubuntu-kvlek) wrote :

I totally agree with Ed, I went back to the 2.5 package just to get the icon back.

David Shepherd (tophitter225-p) wrote :

I read it is supposed to prevent laptop / pc from sleeping with maximised windows???? So far for i'm using Chrome maximised and deluge maximised failed to prevent the laptop/pc from sleeping. Let me get this right they redesigned caffeine took away its usefullness to save on resources and replaced it with something that uses resources and has no beneficial use?? I hope this developer reads all these comments and overturns his idea. I also have gone back to caffeine 2.5 in my opinion the only usable version of the software.

panther_d (dk-mailbox) wrote :

I also think this is a highly undesirable decision - effectively makes Caffeine useless for me.

And I wonder why this happens so often in the linux world of late - there's a perfectly useful little tool, then by some strange decision it gets rendered pointless.

Any chance to get this back? Make it an option if you will, but otherwise I'll need a replacement application for Caffeine.

Dirk Siemer (dirk-siemer) wrote :

OK guys, the solution is easy:

Open

https://launchpad.net/~caffeine-developers/+archive/ppa/+packages

and select package caffeine - 2.5

If the tree is open download the package caffeine_2.5_all.deb ... it works fine with 14.04

:-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions