Missing dependancy of fastimport plugin

Bug #715610 reported by Massimiliano Alberti on 2011-02-09
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Bazaar
Status tracked in Trunk
2.4
Medium
John A Meinel
Trunk
Medium
John A Meinel
Bazaar Windows Installers
Medium
John A Meinel

Bug Description

I don't know if I should write it here or in the fastimport bug tracker. In the Windows Installer of 2.3.0 the fastimport plugin is missing the fastimport python module. To test:

bzr fast-export [folder of a repository] and you should receive this:

bzr: ERROR: Unable to import library "fastimport": bzr-fastimport requires the fasimport python module

(there is even a small error in the error message: they call it the FASIMPORT without the T :-) )

Related branches

Vincent Ladeuil (vila) on 2011-02-09
affects: bzr → bzr-windows-installers
Jelmer Vernooij (jelmer) on 2011-02-09
Changed in bzr-fastimport:
status: New → Invalid
Richard Bateman (taxilian) wrote :

wait... are you serious? You marked this as invalid and didn't even bother to explain what it is? That being the case, it's probably something simple... but those of us who are missing something and have the same issue have to track it down because nobody bothered to update the issue with whatever the simple explanation is. Thanks, guys.

Hi Richard,

Richard Bateman wrote:
> wait... are you serious? You marked this as invalid and didn't even
> bother to explain what it is? That being the case, it's probably
> something simple... but those of us who are missing something and have
> the same issue have to track it down because nobody bothered to update
> the issue with whatever the simple explanation is. Thanks, guys.

The bug is still open.

What happened is Massimiliano marked this bug as affecting
bzr-fastimport *in addition to* bzr-windows-installers, then Jelmer
marked the link with bzr-fastimport as invalid. That's correct: there's
no fix to be done in the bzr-fastimport project itself, this seems to be
purely an installer issue.

If you look at the change Jelmer made you can see it is only speaking
about bzr-fastimport, not bzr-windows-installers:

Jelmer Vernooij wrote:
> ** Changed in: bzr-fastimport
> Status: New => Invalid

And you can see on the web page the bzr-windows-installers part of this
bug is still open, not invalid.

I hope this clarifies the status for you.

-Andrew.

Maxim (maximsch2) wrote :

Same problem in windows installer version 2.3.1

Maxim (maximsch2) wrote :

Same problem still present in 2.3.3

Martin Pool (mbp) wrote :

re comment #2 see bug 790034.

pfrenssen (pieter-frenssen) wrote :

For people missing the python-fastimport module on Ubuntu, it can be found in this PPA: https://launchpad.net/~bzr/+archive/proposed

$ sudo add-apt-repository ppa:bzr/proposed
$ sudo apt-get update
$ sudo apt-get install python-fastimport

Jelmer Vernooij (jelmer) wrote :

hi Pieter, the bzr-fastimport package should automatically pull in python-fastimport. Is that not working for you?

Martin Pool (mbp) wrote :

On 5 August 2011 19:46, Jelmer Vernooij <email address hidden> wrote:
> hi Pieter, the bzr-fastimport package should automatically pull in
> python-fastimport. Is that not working for you?

As far as I know this is a Windows-packaging-specific bug. Perhaps
Pieter was trying to +provide a workaround and didn't realize that?

m4v (m4v) wrote :

got this bug in Ubuntu 10.04, the package bzr-fastimport exists while python-fastimport does not, "apt-cache search fastimport" only yields bzr-fastimport in current 10.04

In Ubuntu 11.04 seems to be ok.

Jelmer Vernooij (jelmer) wrote :

On Fri, Sep 23, 2011 at 10:07:04PM -0000, m4v wrote:
> got this bug in Ubuntu 10.04, the package bzr-fastimport exists while
> python-fastimport does not, "apt-cache search fastimport" only yields
> bzr-fastimport in current 10.04

> In Ubuntu 11.04 seems to be ok.
The bzr-fastimport package in Ubuntu 10.04 still included
python-fastimport, so there was no need for the separate package.

Are you perhaps running an external version of bzr-fastimport?

Cheers,

Jelmer

Changed in bzr-windows-installers:
status: New → Confirmed
importance: Undecided → High
Alexander Belchenko (bialix) wrote :

Due to existing method of building standalone bzr.exe fastimport library should be listed in bzr's setup.py

affects: bzr-fastimport → bzr
Changed in bzr:
status: Invalid → Confirmed
importance: Undecided → Medium
Changed in bzr-windows-installers:
importance: High → Medium
status: Confirmed → Fix Committed
Changed in bzr-windows-installers:
assignee: nobody → John A Meinel (jameinel)
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers