Some expected smart server errors cause client tracebacks

Bug #381329 reported by Jonathan Lange on 2009-05-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Andrew Bennetts
1.15
Critical
Unassigned

Bug Description

When using a Bazaar 1.15 smart server and a Bazaar 1.15 clients, the following operations raise client-side tracebacks:

  - pushing to a new branch without write permissions
  - pushing to an existing branch without write permissons

To reproduce the first bug, do the following with Bazaar 1.15

  $ cd /tmp
  $ bzr init some-branch
  $ cd some-branch
  $ bzr push bzr+ssh://localhost/usr/new-branch

Andrew Bennetts (spiv) wrote :

The cause is fairly straightforward: bzrlib/bzrdir.py issues some HPSS calls directly (in RemoteBzrDirFormat) without taking care to catch and translate ErrorFromSmartServer. I'll submit a fix shortly.

Andrew Bennetts (spiv) wrote :

Fix has landed in bzr.dev r4401. Not marking this as Fix Released until this gets cherrypicked for 1.15.1 (or until the RM for 1.15.1 decides not to).

Changed in bzr:
status: Triaged → Fix Committed
Martin Pool (mbp) wrote :

was cherrypicked to 1.15.1

Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers