Bazaar Version Control System

bzrlib.errors.IllegalUseOfScopeReplacer: ScopeReplacer object 'StringIO'

Reported by Adi Roiban on 2011-12-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Jelmer Vernooij
2.3
High
Jelmer Vernooij
2.4
High
Jelmer Vernooij

Bug Description

I am trying to update the BzrPoller from buildbot contrib file.

The updated Python code is at http://pastebin.ubuntu.com/772280/

The full traceback is at http://pastebin.ubuntu.com/772289/

The error occurs when I try to use more than one BzrPoller for the changesources.

Let me know if anything else is required.

Cheers,
Adi

Related branches

Jelmer Vernooij (jelmer) on 2011-12-16
Changed in bzr:
status: New → Confirmed
importance: Undecided → High
Jelmer Vernooij (jelmer) on 2011-12-18
Changed in bzr:
status: Confirmed → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Martin Packman (gz) wrote :

See also IRC log: <http://irclogs.ubuntu.com/2011/12/16/%23bzr.html#t14:59>

The problem is basically bug 396819 which still needs a more complete fix, and isn't sensible to backport to 2.3 unfortunately. The workaround to do the following before spawning threads did seem to help though:

    from bzrlib import config
    config.StringIO()

This does the thunk before beforehand so there's no chance for a race when it's used later.

Martin Packman (gz) on 2011-12-21
Changed in bzr:
milestone: none → 2.3.5
status: In Progress → Fix Released
milestone: 2.3.5 → 2.5b5
status: Fix Released → In Progress
Vincent Ladeuil (vila) on 2012-01-12
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers