bzrlib.initialize() misses out the default prober

Bug #905218 reported by ChrisCauser on 2011-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Jelmer Vernooij

Bug Description

A script that used to work in 2.4 has just broken when I upgrade to the 2.5 daily ppa.

http://bazaar.launchpad.net/~chy-causer/bzr/bzr-term-info/view/head:/__main__.py

I get the error reported here (when I remove the except in line 49)

http://paste.ubuntu.com/771991/

Which in turn is caused because bzrlib.bzrdir, which registers the BzrProber prober at line 1143 (commit 6349), is not being imported when bzrlib is initialized. The script above can be fixed with an explicit "import bzrlib.bzrdir", but vila says that initialize() should be sufficient and the fact it isn't should be considered a bug, which is why I am filing it here.

If I you require any more information please let me know.

Related branches

Vincent Ladeuil (vila) wrote :

Sounds like a regression from 2.4 we want to fix before the next 2.5 release, so: Critical but hopefully shallow.

Changed in bzr:
status: New → Confirmed
importance: Undecided → Critical
Jelmer Vernooij (jelmer) on 2011-12-16
Changed in bzr:
status: Confirmed → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 2.5b5
Jelmer Vernooij (jelmer) on 2011-12-20
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers