bzr crashed with TypeError in format_patch_date(): unsupported operand type(s) for +: 'NoneType' and 'int'

Bug #847435 reported by Richie Ward on 2011-09-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Jelmer Vernooij
bzr (Ubuntu)
Medium
Jelmer Vernooij

Bug Description

I was running bzr diff on my project. I have made a sizable amount of changes to my code before running it.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: bzr 2.4.0-3ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
BzrDebugFlags: set()
BzrVersion: 2.4.0
CommandLine: ['/usr/bin/bzr', 'diff']
CrashDb: bzr
Date: Sun Sep 11 23:43:40 2011
ExecutablePath: /usr/bin/bzr
FileSystemEncoding: UTF-8
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110831)
InterpreterPath: /usr/bin/python2.7
Locale: en_GB.UTF-8
PackageArchitecture: all
Platform: Linux-3.0.0-10-generic-x86_64-with-Ubuntu-11.10-oneiric
ProcCmdline: /usr/bin/python /usr/bin/bzr diff
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
PythonVersion: 2.7.2
SourcePackage: bzr
Title: bzr crashed with TypeError in format_patch_date(): unsupported operand type(s) for +: 'NoneType' and 'int'
UpgradeStatus: No upgrade log present (probably fresh install)
UserEncoding: UTF-8
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Richie Ward (richies) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Jelmer Vernooij (jelmer) wrote :

It looks like the problem is that WorkingTree.get_file_mtime returns None if it can't find a matching entry rather than e.g. raising TimestampUnavailable.

I think this should be fixed if you run "bzr rm" (no arguments)

Changed in bzr (Ubuntu):
status: New → Triaged
status: Triaged → Confirmed
importance: Undecided → Medium

The attachment "wt-get-file-mtime.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
John A Meinel (jameinel) on 2011-09-12
affects: bzr (Ubuntu) → bzr
Jelmer Vernooij (jelmer) on 2011-09-21
Changed in bzr (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Vincent Ladeuil (vila) on 2011-09-24
Changed in bzr:
milestone: none → 2.5b2
status: Confirmed → Fix Released
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2011-11-04
Changed in bzr (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.5.0~beta2-0ubuntu1

---------------
bzr (2.5.0~beta2-0ubuntu1) precise; urgency=low

  * New upstream release.
   + Fixes compatibility with cython 0.15. LP: #837221
   + Fixes handling of timestamps in diffs for absent files in working tree.
     LP: #847435
   + Fixes overflow error in dirstate when dealing with large files.
     LP: #683191
  * Merge from Debian. Remaining changes:
   + Drop build dependencies on python-{subunit,meliae,lzma,medusa}, which are
     not in main.
   + Disable support for running selftest in parallel (requires subunit).
 -- Jelmer Vernooij <email address hidden> Fri, 04 Nov 2011 22:55:11 +0100

Changed in bzr (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers