bzrlib.tests.blackbox.test_version.TestVersionUnicodeOutput.test_unicode_bzr_home fails

Bug #822571 reported by Vincent Ladeuil on 2011-08-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil
2.4
High
Vincent Ladeuil

Bug Description

This test has been failing recently on all Ubuntu babune slaves

Related branches

Vincent Ladeuil (vila) wrote :

Crude fix in progress, roughly the issue is that we acquire BZR_HOME from the environment without decoding if it's not in ascii.

The obvious fix is to decode it as utf8 even if strictly speaking we could try fs encoding.

Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
importance: Undecided → High
status: New → Confirmed
Vincent Ladeuil (vila) on 2011-08-08
Changed in bzr:
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2011-08-08
tags: added: babune
Vincent Ladeuil (vila) on 2011-08-09
Changed in bzr:
status: In Progress → Fix Released
milestone: none → 2.5b1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers