`make chm-sphinx` failed with errors

Bug #782289 reported by Alexander Belchenko on 2011-05-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil
2.3
High
Vincent Ladeuil

Bug Description

I'm unable to build installer because `make chm-sphinx` is failed with errors:

C:\work\Bazaar\bzr-2a\bzr.dev>make chm-sphinx PYTHON=py26 > build.log
makefile:87: предупреждение: переопределение команд для цели `TAGS'
makefile:84: предупреждение: старые команды для цели `TAGS' игнорируются
make.EXE: Циклическая зависимость doc/en/Makefile <- doc/en/Makefile пропущена.
make.EXE: Циклическая зависимость doc/en/make.bat <- doc/en/make.bat пропущена.
Making output directory...
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\configuration-help.txt:613: (ERROR/3) Unexpected indentation.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\configuration-help.txt:620: (WARNING/2) Title underline too short.

bzr.default_mergetool
~~~~~~~~~~~~~~~~~
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\configuration-help.txt:620: (WARNING/2) Title underline too short.

bzr.default_mergetool
~~~~~~~~~~~~~~~~~
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-help.txt:21: (WARNING/2) Option list ends without a blank line; unexpec
ted unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-help.txt:23: (ERROR/3) Unexpected indentation.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-help.txt:24: (WARNING/2) Block quote ends without a blank line; unexpec
ted unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-help.txt:30: (WARNING/2) Option list ends without a blank line; unexpec
ted unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-repository-help.txt:18: (WARNING/2) Option list ends without a blank li
ne; unexpected unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-repository-help.txt:20: (ERROR/3) Unexpected indentation.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-repository-help.txt:21: (WARNING/2) Block quote ends without a blank li
ne; unexpected unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\init-repository-help.txt:27: (WARNING/2) Option list ends without a blank li
ne; unexpected unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\upgrade-help.txt:19: (WARNING/2) Option list ends without a blank line; unex
pected unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\upgrade-help.txt:21: (ERROR/3) Unexpected indentation.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\upgrade-help.txt:22: (WARNING/2) Block quote ends without a blank line; unex
pected unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\user-reference\upgrade-help.txt:28: (WARNING/2) Option list ends without a blank line; unex
pected unindent.
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\whats-new\whats-new-in-2.1.txt:: WARNING: document isn't included in any toctree
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\whats-new\whats-new-in-2.2.txt:: WARNING: document isn't included in any toctree
C:\work\Bazaar\bzr-2a\bzr.dev\doc\en\whats-new\whats-new-in-2.3.txt:: WARNING: document isn't included in any toctree

As result of these failures build process broken.

Related branches

Vincent Ladeuil (vila) wrote :

What bzr version ? 2.3.3 ?

13.05.2011 20:03, Vincent Ladeuil пишет:
> What bzr version ? 2.3.3 ?

That's for bzr.dev trunk

--
All the dude wanted was his rug back

Alexander Belchenko (bialix) wrote :

13.05.2011 20:03, Vincent Ladeuil пишет:
> What bzr version ? 2.3.3 ?

Here's output for bzr/2.3

C:\work\Bazaar\bzr-2a\2.3>make chm-sphinx PYTHON=py26 > build.log
makefile:82: предупреждение: переопределение команд для цели `TAGS'
makefile:79: предупреждение: старые команды для цели `TAGS' игнорируются
make: Циклическая зависимость doc/en/Makefile <- doc/en/Makefile
пропущена.
make: Циклическая зависимость doc/en/make.bat <- doc/en/make.bat
пропущена.
C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\ignore-help.txt:80:
(WARNING/2)
Inline emphasis start-string without end-string.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-help.txt:21:
(WARNING/2) Option list ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-help.txt:23:
(ERROR/3) Unexpected indentation.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-help.txt:24:
(WARNING/2) Block quote ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-help.txt:30:
(WARNING/2) Option list ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-repository-help.txt:18:
(WARNING/2) Option list ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-repository-help.txt:20:
(ERROR/3) Unexpected indentation.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-repository-help.txt:21:
(WARNING/2) Block quote ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-repository-help.txt:27:
(WARNING/2) Option list ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\upgrade-help.txt:19:
(WARNING/2)
 Option list ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\upgrade-help.txt:21:
(ERROR/3) Unexpected indentation.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\upgrade-help.txt:22:
(WARNING/2)
 Block quote ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\upgrade-help.txt:28:
(WARNING/2)
 Option list ends without a blank line; unexpected unindent.

C:\work\Bazaar\bzr-2a\2.3\doc\en\whats-new\whats-new-in-2.1.txt::
WARNING: document isn't included in any toctree
C:\work\Bazaar\bzr-2a\2.3\doc\en\whats-new\whats-new-in-2.2.txt::
WARNING: document isn't included in any toctree
make: *** [chm-sphinx] Ошибка 1

Alexander Belchenko (bialix) wrote :

14.05.2011 9:35, Alexander Belchenko пишет:
> 13.05.2011 20:03, Vincent Ladeuil пишет:
>> What bzr version ? 2.3.3 ?
>
> Here's output for bzr/2.3
>
> C:\work\Bazaar\bzr-2a\2.3>make chm-sphinx PYTHON=py26 > build.log

> C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-help.txt:23:
> (ERROR/3) Unexpected indentation.
>
> C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\init-repository-help.txt:20:
> (ERROR/3) Unexpected indentation.
>
> C:\work\Bazaar\bzr-2a\2.3\doc\en\user-reference\upgrade-help.txt:21:
> (ERROR/3) Unexpected indentation.

Those 3 errors here because docutils doesn't understand option names
with dots, e.g. --1.14 (in the description of the available formats).
I believe this is known bug, just can't find it right now.

I think that should be fixed in docutils upstream and somebody from
bzr community should work on this (maybe even me).

But right now to unblock the installers I have to suppress error code
from sphinx with following patch:

=== modified file Makefile
--- Makefile 2011-04-15 23:32:43 +0000
+++ Makefile 2011-05-14 11:06:17 +0000
@@ -179,11 +179,11 @@
 # Note: HtmlHelp Workshop needs to be used on the generated hhp files
 # to generate the final chm files.
 chm-sphinx: $(SPHINX_DEPENDENCIES)
- cd doc/en && make htmlhelp
- cd doc/es && make htmlhelp
- cd doc/ru && make htmlhelp
- cd doc/ja && make htmlhelp
- cd doc/developers && make htmlhelp
+ cd doc/en && make htmlhelp || echo Error supressed
+ cd doc/es && make htmlhelp || echo Error supressed
+ cd doc/ru && make htmlhelp || echo Error supressed
+ cd doc/ja && make htmlhelp || echo Error supressed
+ cd doc/developers && make htmlhelp || echo Error supressed

 ### Documentation Website ###

Or you have better ideas?

--
All the dude wanted was his rug back

Alexander Belchenko (bialix) wrote :

Full list of errors/warnings to build chm-sphinx for all languages

Changed in bzr:
status: New → Confirmed
importance: Undecided → High
Alexander Belchenko (bialix) wrote :

I forced myself to avoid to set Critical.

Vincent Ladeuil (vila) wrote :

Reproduced locally.

I'm pretty sure there is a dupe about option names with '.' which are not handled.

Changed in bzr:
importance: High → Medium
Vincent Ladeuil (vila) wrote :

argh, sry bialix, we crossed on the wire (I had the page open for quite some time)

I think you're right to use your patch locally but I'd rather have the doc fixed (or include some workaround for the option names).

I think we don't encounter the issue elsewhere because sphinx is still not the default doc tool, but we should do that sooner than later, so better fix the doc anyway.

Changed in bzr:
importance: Medium → High
Vincent Ladeuil (vila) wrote :

@bialix: IIRC (my make memory is a bit dusty), running 'make -k chm-sphinx' should have the same effect as your patch

Vincent Ladeuil (vila) wrote :

I've got some fixex, almost made me cry to find an XXX perfectly explaining both the issue and how to fix one of the issues....

Changed in bzr:
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2011-05-14
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2011-05-16
Changed in bzr:
milestone: none → 2.4b3
Vincent Ladeuil (vila) on 2011-05-16
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments