'bzr pull' uses generic iter_changes api

Bug #780677 reported by John A Meinel on 2011-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
John A Meinel

Bug Description

I'm doing some profiling of stuff like pull in a large tree (70k entries). It looks like it is falling back to the generic InterTree for iter_changes. My guess is because pull is probably using the DirStateRevisionTree on one side, and a RevisionTree on the other. This used to be faster, but now we can do RevisonTree vs RevisionTree faster and we should do so.

Related branches

John A Meinel (jameinel) wrote :

I'm pretty sure this also affects 'bzr update', but haven't tested it specifically.

John A Meinel (jameinel) on 2011-05-10
Changed in bzr:
assignee: nobody → John A Meinel (jameinel)
status: Confirmed → In Progress
John A Meinel (jameinel) on 2011-05-12
Changed in bzr:
milestone: none → 2.4b3
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers