bzr branch fails with initialize() got an unexpected keyword argument 'name'

Bug #774081 reported by Julien SAFAR on 2011-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned
Loom
Medium
Jelmer Vernooij

Bug Description

Hello,

I have an error when I try to get a launchpad repo with bzr.
Could you help me?

bzr: ERROR: exceptions.TypeError: initialize() got an unexpected keyword argument 'name'

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 853, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 1055, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 661, in run_argv_aliases
    return self.run_direct(**all_cmd_args)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 665, in run_direct
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 122, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 156, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/builtins.py", line 1232, in run
    source_branch=br_from)
  File "/usr/lib/python2.6/dist-packages/bzrlib/bzrdir.py", line 1191, in sprout
    revision_id=revision_id, repository_policy=repository_policy)
  File "/usr/lib/python2.6/dist-packages/bzrlib/decorators.py", line 140, in read_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/branch.py", line 1164, in sprout
    result = to_bzrdir.create_branch()
  File "/usr/lib/python2.6/dist-packages/bzrlib/bzrdir.py", line 1595, in create_branch
    return self._format.get_branch_format().initialize(self)
  File "/usr/lib/python2.6/dist-packages/bzrlib/plugins/loom/branch.py", line 808, in initialize
    super(LoomFormatMixin, self).initialize(a_bzrdir, name=None)
TypeError: initialize() got an unexpected keyword argument 'name'

bzr 2.1.2 on python 2.6.6 (Linux-2.6.32-5-686-i686-with-debian-6.0.1)
arguments: ['/usr/bin/bzr', 'branch', 'lp:ocsinventory-unix-agent']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'fr_FR.UTF-8'
plugins:
  bzrtools /usr/lib/python2.6/dist-packages/bzrlib/plugins/bzrtools [2.1.0]
  email /usr/lib/python2.6/dist-packages/bzrlib/plugins/email [unknown]
  fastimport /usr/lib/python2.6/dist-packages/bzrlib/plugins/fastimport [0.9.0dev]
  launchpad /usr/lib/python2.6/dist-packages/bzrlib/plugins/launchpad [2.1.2]
  loom /usr/lib/python2.6/dist-packages/bzrlib/plugins/loom [2.1.0]
  netrc_credential_store /usr/lib/python2.6/dist-packages/bzrlib/plugins/netrc_credential_store [2.1.2]
  news_merge /usr/lib/python2.6/dist-packages/bzrlib/plugins/news_merge [2.1.2]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

Jelmer Vernooij (jelmer) wrote :

This is fixed in bzr-loom trunk.

Changed in bzr:
status: New → Invalid
Changed in bzr-loom:
status: New → Fix Committed
importance: Undecided → Medium
Julien SAFAR (jsasys) wrote :

Hi Jelmer,

It was what I think but you can see my error message:

File "/usr/lib/python2.6/dist-packages/bzrlib/plugins/loom/branch.py", line 808, in initialize
    super(LoomFormatMixin, self).initialize(a_bzrdir, name=None)
TypeError: initialize() got an unexpected keyword argument 'name'

But I use directly bzr-loom trunk :

bzr info /usr/lib/python2.6/dist-packages/bzrlib/plugins/loom
Standalone tree (format: 2a)
Location:
  branch root: .

Related branches:
  parent branch: bzr+ssh://bazaar.launchpad.net/%2Bbranch/bzr-loom/

On Sat, 2011-04-30 at 14:57 +0000, Julien SAFAR wrote:
> Hi Jelmer,
>
> It was what I think but you can see my error message:
>
> File "/usr/lib/python2.6/dist-packages/bzrlib/plugins/loom/branch.py", line 808, in initialize
> super(LoomFormatMixin, self).initialize(a_bzrdir, name=None)
> TypeError: initialize() got an unexpected keyword argument 'name'
>
> But I use directly bzr-loom trunk :
>
> bzr info /usr/lib/python2.6/dist-packages/bzrlib/plugins/loom
> Standalone tree (format: 2a)
> Location:
> branch root: .
>
> Related branches:
> parent branch: bzr+ssh://bazaar.launchpad.net/%2Bbranch/bzr-loom/

What revno are you using, and what version of bzr?

Jelmer

Julien SAFAR (jsasys) wrote :

Hi ,

I use last revno:
bzr update show :
Tree is up to date at revision 132 of branch /usr/lib/python2.6/dist-packages/bzrlib/plugins/loom

This is my bzr version:

Bazaar (bzr) 2.1.2
  Python interpreter: /usr/bin/python 2.6.6
  Python standard library: /usr/lib/python2.6
  Platform: Linux-2.6.32-5-686-i686-with-debian-6.0.1

Thanks for your help.

Jelmer Vernooij (jelmer) wrote :

On Sat, 2011-04-30 at 16:02 +0000, Julien SAFAR wrote:
> Hi ,
>
> I use last revno:
> bzr update show :
> Tree is up to date at revision 132 of branch /usr/lib/python2.6/dist-packages/bzrlib/plugins/loom
>
> This is my bzr version:
>
> Bazaar (bzr) 2.1.2
> Python interpreter: /usr/bin/python 2.6.6
> Python standard library: /usr/lib/python2.6
> Platform: Linux-2.6.32-5-686-i686-with-debian-6.0.1
>
> Thanks for your help.
The version of bzr-loom you are using is incompatible with this version
of bzr. I think bzr-loom trunk just supports bzr 2.3 and 2.4.

If you're using bzr from your distribution (Debian?), you should be able
to also use the bzr-loom package from squeeze.

Cheers,

Jelmer

Julien SAFAR (jsasys) wrote :

Hi Jelmer,

Thanks for your reply.
The problem is I installed Debian bzr-loom package:

Package: bzr-loom
Priority: optional
Section: vcs
Installed-Size: 280
Maintainer: Debian Bazaar Maintainers <email address hidden>
Architecture: all
Version: 2.1-1

But I have this problem it's why I create this bug.
After I thought that perhaps last version of bzr-loom will solved the problem but if now bzr and bzr-loom are not compatible I will try to upgrade bzr , it is my last solution

Thanks for your help
Best Regards

Julien SAFAR (jsasys) wrote :

Hi Jelmer,

Just to inform you I try to get bzr last version on launchpad and it works.
Bazaar (bzr) 2.4b2

So now I have last version of bzr and last version of bzr-loom and it works fine.

Thanks for your help.
BR
Julien

Jelmer Vernooij (jelmer) wrote :

On Sat, 2011-04-30 at 16:31 +0000, Julien SAFAR wrote:
> Hi Jelmer,
>
> Thanks for your reply.
> The problem is I installed Debian bzr-loom package:
>
> Package: bzr-loom
> Priority: optional
> Section: vcs
> Installed-Size: 280
> Maintainer: Debian Bazaar Maintainers <email address hidden>
> Architecture: all
> Version: 2.1-1
>
> But I have this problem it's why I create this bug.
What problem do you have with bzr-loom 2.1-1 ?

Cheers,

Jelmer

Jelmer Vernooij (jelmer) on 2011-08-18
Changed in bzr-loom:
milestone: none → 2.2
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2012-02-26
Changed in bzr-loom:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers