bzr under python2.7 fails: _ReportingFileSocket.readline lacks size argument

Bug #693880 reported by Jelmer Vernooij on 2010-12-23
186
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Vincent Ladeuil
2.2
High
Vincent Ladeuil
bzr (Debian)
Fix Released
Undecided
Jelmer Vernooij
bzr (Ubuntu)
Critical
Bilal Akhtar
Maverick
Critical
Unassigned
Natty
Critical
Bilal Akhtar

Bug Description

gwenhwyvar:~/launchpad/lp-branches% BZR_PDB=1 bzr branch --no-tree lp:~jelmer/launchpad/buildd-secret-tokens
bzr: failed to report crash using apport:
     OSError(17, 'File exists')
bzr: ERROR: exceptions.TypeError: readline() takes exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 923, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1123, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 691, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 710, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/builtins.py", line 1185, in run
    from_location)
  File "/usr/lib/python2.7/dist-packages/bzrlib/bzrdir.py", line 806, in open_tree_or_branch
    bzrdir = klass.open(location)
  File "/usr/lib/python2.7/dist-packages/bzrlib/bzrdir.py", line 716, in open
    t = get_transport(base, possible_transports=possible_transports)
  File "/usr/lib/python2.7/dist-packages/bzrlib/lazy_import.py", line 128, in __call__
    return obj(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1638, in get_transport
    return _get_transport(base, possible_transports)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1582, in _get_transport
    base = directories.dereference(base)
  File "/usr/lib/python2.7/dist-packages/bzrlib/directory_service.py", line 58, in dereference
    return service().look_up(name, url)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_directory.py", line 69, in look_up
    return self._resolve(url)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_directory.py", line 124, in _resolve
    result = resolve.submit(service)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_registration.py", line 272, in submit
    self._authenticated)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_registration.py", line 195, in send_request
    result = method(*method_params)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1575, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_registration.py", line 74, in request
    response = self._opener.open(request)
  File "/usr/lib/python2.7/urllib2.py", line 392, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 410, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 370, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/_urllib2_wrappers.py", line 757, in https_open
    return self.do_open(HTTPSConnection, request)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/_urllib2_wrappers.py", line 659, in do_open
    response = connection.getresponse()
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/_urllib2_wrappers.py", line 263, in getresponse
    self._response = httplib.HTTPConnection.getresponse(self)
  File "/usr/lib/python2.7/httplib.py", line 1027, in getresponse
    response.begin()
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/http/_urllib2_wrappers.py", line 184, in begin
    httplib.HTTPResponse.begin(self)
  File "/usr/lib/python2.7/httplib.py", line 439, in begin
    self.msg = HTTPMessage(self.fp, 0)
  File "/usr/lib/python2.7/mimetools.py", line 25, in __init__
    rfc822.Message.__init__(self, fp, seekable)
  File "/usr/lib/python2.7/rfc822.py", line 108, in __init__
    self.readheaders()
  File "/usr/lib/python2.7/httplib.py", line 280, in readheaders
    line = self.fp.readline(_MAXLINE + 1)
TypeError: readline() takes exactly 1 argument (2 given)

bzr 2.3.0dev5 on python 2.7.1 (Linux-2.6.37-10-generic-x86_64-with-Ubuntu-11.04-natty)
arguments: ['/usr/bin/bzr', 'branch', '--no-tree', 'lp:~jelmer/launchpad/buildd-secret-tokens']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_IE.utf8'
plugins:
  bash_completion /usr/lib/python2.7/dist-packages/bzrlib/plugins/bash_completion [2.3.0dev5]
  bisect /home/jelmer/.bazaar/plugins/bisect [1.1.0.pre.0]
  builddeb /home/jelmer/.bazaar/plugins/builddeb [2.2.0]
  builder /home/jelmer/.bazaar/plugins/builder [unknown]
  bzrtools /home/jelmer/.bazaar/plugins/bzrtools [2.3.0]
  colocated /home/jelmer/.bazaar/plugins/colocated [0.4.16dev]
  commitfromnews /home/jelmer/.bazaar/plugins/commitfromnews [unknown]
  dbus /home/jelmer/.bazaar/plugins/dbus [0.1.0dev]
  email /home/jelmer/.bazaar/plugins/email [unknown]
  explorer /home/jelmer/.bazaar/plugins/explorer [1.1.0dev2]
  fastimport /home/jelmer/.bazaar/plugins/fastimport [0.10.0dev]
  gardener /home/jelmer/.bazaar/plugins/gardener [unknown]
  git /home/jelmer/.bazaar/plugins/git [0.5.3dev]
  grep /usr/lib/python2.7/dist-packages/bzrlib/plugins/grep [0.5.0dev]
  gtk /home/jelmer/.bazaar/plugins/gtk [0.99.1]
  hg /home/jelmer/.bazaar/plugins/hg [0.2.0dev]
  keywords /home/jelmer/.bazaar/plugins/keywords [unknown]
  launchpad /usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad [2.3.0dev5]
  loggerhead /home/jelmer/.bazaar/plugins/loggerhead [1.17.0]
  loom /usr/lib/python2.7/dist-packages/bzrlib/plugins/loom [2.2.1dev]
  lpreview_body /home/jelmer/.bazaar/plugins/lpreview_body [unknown]
  mtn /home/jelmer/.bazaar/plugins/mtn [unknown]
  netrc_credential_store /usr/lib/python2.7/dist-packages/bzrlib/plugins/netrc_credential_store [2.3.0dev5]
  news_merge /usr/lib/python2.7/dist-packages/bzrlib/plugins/news_merge [2.3.0dev5]
  pipeline /usr/lib/python2.7/dist-packages/bzrlib/plugins/pipeline [1.0.0]
  plugin_info /home/jelmer/.bazaar/plugins/plugin_info [1.3.0dev]
  pqm /home/jelmer/.bazaar/plugins/pqm [1.4.0dev]
  qbzr /home/jelmer/.bazaar/plugins/qbzr [0.20.0dev1]
  rewrite /home/jelmer/.bazaar/plugins/rewrite [0.6.2dev]
  search /home/jelmer/.bazaar/plugins/search [1.7.0dev]
  stats /home/jelmer/.bazaar/plugins/stats [0.1.0dev]
  svn /home/jelmer/.bazaar/plugins/svn [1.0.5dev]
  testrunner /home/jelmer/.bazaar/plugins/testrunner [unknown]
  trac /home/jelmer/.bazaar/plugins/trac [unknown]
  upload /usr/lib/python2.7/dist-packages/bzrlib/plugins/upload [1.0.0]
  wikkid /usr/lib/python2.7/dist-packages/bzrlib/plugins/wikkid [unknown]
  xmloutput /usr/lib/python2.7/dist-packages/bzrlib/plugins/xmloutput [0.8.7.dev]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.
**** entering debugger
> /usr/lib/python2.7/httplib.py(280)readheaders()
-> line = self.fp.readline(_MAXLINE + 1)
(Pdb) print self.fp
<bzrlib.transport.http._urllib2_wrappers._ReportingFileSocket object at 0x1e8c210>

Related branches

Jelmer Vernooij (jelmer) on 2010-12-23
Changed in bzr:
status: New → Confirmed
importance: Undecided → High
Martin Packman (gz) on 2010-12-24
tags: added: python2.7
Artur Rona (ari-tczew) on 2010-12-24
tags: added: python27
removed: python2.7
Vincent Ladeuil (vila) wrote :

This is a rather severe API break IMNSHO, we should fix it ASAP.

Vincent Ladeuil (vila) wrote :

It's a one-line fix, make that two lines to be compatible with older pythons, let's target 2.2 too.

Changed in bzr:
importance: High → Critical
Vincent Ladeuil (vila) wrote :

May be I should explain a bit more: trying to setup a natty slave I came across: http://babune.ladeuil.net:24842/job/seltest-natty/1/console

https access to launchpad is now impossible, so I bumped the importance to Critical

Vincent Ladeuil (vila) on 2010-12-24
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2010-12-24
Changed in bzr:
milestone: none → 2.3b5
Vincent Ladeuil (vila) on 2010-12-24
Changed in bzr:
status: In Progress → Fix Released
Artur Rona (ari-tczew) wrote :

Fixed in bzr 2.3b5. We should upgrade it for Ubuntu or wait for Debian response.

Changed in bzr (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Jelmer Vernooij (jelmer) wrote :

I'm going to upload a package to sid.

Jelmer Vernooij (jelmer) wrote :

Unfortunately there are a couple of other problems that show up when running the test suite with python 2.7. I'd like to wait for beta 5 (and resolve the rest of there issues) before uploading anything to sid.

Artur Rona (ari-tczew) wrote :

There is also experimental. However, I agree that we shouldn't handle even with experimental if package couldn't build.

Bilal Akhtar (bilalakhtar) wrote :

I applied vila's commit #5580 to lp:bzr in this debdiff. Would be good if someone sponsored it.

Artur Rona (ari-tczew) wrote :

@Bilal Akhtar: My question is did you try to build it? Because on my natty is FTBFS. I was trying to build this patch some days ago.

On 12/30/2010 01:54 PM, Artur Rona wrote:
> @Bilal Akhtar: My question is did you try to build it? Because on my
> natty is FTBFS. I was trying to build this patch some days ago.
>
It appears to build well on amd64.

The problem is that selftest doesn't pass with Python 2.7, no? Fixes have recently landed for bug 614595 and bug 637674, which leaves three failures, one from bug 654731 and two from bug 654733.

Bilal Akhtar (bilalakhtar) wrote :

As for the successful build on amd64 about which I mentioned in comment #11, the build was:
https://launchpad.net/~bilalakhtar/+archive/stage/+build/2117223

On Fri, 2010-12-31 at 12:54 +0000, Bilal Akhtar wrote:
> As for the successful build on amd64 about which I mentioned in comment #11, the build was:
> https://launchpad.net/~bilalakhtar/+archive/stage/+build/2117223
That build doesn't seem to have run the Bazaar testsuite (anymore?),
which was what caused my builds to fail. One of the issues the testsuite
shows is fairly serious and could cause data corruption -
https://bugs.launchpad.net/bzr/+bug/654731

Cheers,

Jelmer

Aha, amd64 built fine, but i386 which I was trying to build is FTBFS. That's clear. I'd like to wait for patch which will build package also on i386.

Bilal Akhtar (bilalakhtar) wrote :

Unsubscribed sponsors for now, as we need to resolve the issues detected by selftest first, before we move to fixing this bug.

In the meantime this is a workaround to run bazaar (force usage of python 2.6):

python2.6 `which bzr` branch lp:foo

Replace branch lp:foo with the command you want to run.

My suggestion: make an upload to natty which temporarily fixes this problem by renaming:

#! /usr/bin/python

 in the first line of /usr/bin/bzr to:

#! /usr/bin/python2.6

Bilal Akhtar (bilalakhtar) wrote :

This debdiff forces the use of Python 2.6 both while building the bzrlib and also modifies the /usr/bin/bzr command to ALWAYS use python2.6 . This temporarily fix fixes the problem of selftests and other issues such as this one which came up after the python 2.7 transition.

This patch needs to be reverted once these issues are resolved upstream.

This is a rough debdiff, and I think many changes might be needed in it. Nevertheless, subscribing sponsors.

Bilal Akhtar (bilalakhtar) wrote :

The build of this debdiff actually works on both i386 and amd64, and the selftests run well.

https://launchpad.net/~bilalakhtar/+archive/stage/+build/2121868
https://launchpad.net/~bilalakhtar/+archive/stage/+build/2121867

Bilal Akhtar (bilalakhtar) wrote :

This 'workaround' fix works, just tested on natty.

Martin Pitt (pitti) wrote :

Thanks Bilal! I'll sponsor this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.3.0~beta3-1ubuntu1

---------------
bzr (2.3.0~beta3-1ubuntu1) natty; urgency=low

  * Force usage of python2.6 both while building and when the bzr command
    is executed. This is a temporary change to fix issues caused in bzr
    due to the python 2.7 transition. (LP: #693880)
 -- Bilal Akhtar <email address hidden> Mon, 03 Jan 2011 18:10:35 +0300

Changed in bzr (Ubuntu Natty):
status: Confirmed → Fix Released
Loïc Minier (lool) wrote :
Download full text (4.3 KiB)

This is still an issue for me wtih 2.3.0~beta3-1ubuntu1:
ii bzr 2.3.0~beta3-1ubuntu1 easy to use distributed version control system

bzr branch lp:xyz
bzr: ERROR: exceptions.TypeError: readline() takes exactly 1 argument (2 given)

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 917, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 1117, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 691, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.7/dist-packages/bzrlib/commands.py", line 710, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/builtins.py", line 1185, in run
    from_location)
  File "/usr/lib/python2.7/dist-packages/bzrlib/bzrdir.py", line 806, in open_tree_or_branch
    bzrdir = klass.open(location)
  File "/usr/lib/python2.7/dist-packages/bzrlib/bzrdir.py", line 716, in open
    t = get_transport(base, possible_transports=possible_transports)
  File "/usr/lib/python2.7/dist-packages/bzrlib/lazy_import.py", line 128, in __call__
    return obj(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1638, in get_transport
    return _get_transport(base, possible_transports)
  File "/usr/lib/python2.7/dist-packages/bzrlib/transport/__init__.py", line 1582, in _get_transport
    base = directories.dereference(base)
  File "/usr/lib/python2.7/dist-packages/bzrlib/directory_service.py", line 58, in dereference
    return service().look_up(name, url)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_directory.py", line 69, in look_up
    return self._resolve(url)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_directory.py", line 124, in _resolve
    result = resolve.submit(service)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_registration.py", line 272, in submit
    self._authenticated)
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_registration.py", line 195, in send_request
    result = method(*method_params)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1575, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/dist-packages/bzrlib/plugins/launchpad/lp_registration.py", line 74, in request
    response = self._opener.open(request)
  File "/usr/lib/python2.7/urllib2.py", line 392, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 410, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 370, in _call_chain
    result = func(*args)
  File "/...

Read more...

Bilal Akhtar (bilalakhtar) wrote :

Setting back to confirmed.

It appears that the change which I made gets overridden when the bzr script goes into /usr/bin/ . I am working on this one, and will upload another debdiff in a matter of minutes.

Changed in bzr (Ubuntu Natty):
status: Fix Released → Confirmed
Bilal Akhtar (bilalakhtar) wrote :
Loïc Minier (lool) on 2011-01-03
Changed in bzr (Ubuntu Natty):
assignee: nobody → Loïc Minier (lool)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.3.0~beta3-1ubuntu2

---------------
bzr (2.3.0~beta3-1ubuntu2) natty; urgency=low

  * Revert changes from 2.3.0~beta3-1ubuntu1 as they don't fix the build.
  * New patch, fix-readline-python2.7, from
    https://code.launchpad.net/~vila/bzr/2.2-693880-ssl-readline; LP: #693880.
 -- Loic Minier <email address hidden> Mon, 03 Jan 2011 18:43:13 +0100

Changed in bzr (Ubuntu Natty):
status: Confirmed → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

This bug finally gets fixed for good in the -1ubuntu3 upload:

bzr (2.3.0~beta3-1ubuntu3) natty; urgency=low

  * Revert back to 2.3.0~beta3-1ubuntu1 as it's not just the readline() issue
    causing problems, but bzr will corrupt .bzr dirs with python 2.7, see
    LP #654731.
  * Really use python2.6 by setting --executable to /usr/bin/python2.6 instead
    of /usr/bin/python in debian/rules; thanks Bilal Akhtar.

Thanks Loic Minier for the quick application of the fix!

Bilal Akhtar (bilalakhtar) wrote :

Fixed in natty for now.

Bazaar Maintainers: Please drop the ubuntu changes in the bzr package when the python 2.7 transitional issues get fixed upstream.

Changed in bzr (Ubuntu Natty):
assignee: Loïc Minier (lool) → Bilal Akhtar (bilalakhtar)

Accepted bzr into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bzr (Ubuntu Maverick):
importance: Undecided → Critical
status: New → Fix Committed
tags: added: verification-needed
Martin Pool (mbp) on 2011-04-21
summary: - _ReportingFileSocket.readline lacks size argument
+ bzr under python2.7 fails: _ReportingFileSocket.readline lacks size
+ argument
Martin Pool (mbp) wrote :

SRU verification:

This problem only manifests under python2.7 and bzr is not likely to run there on maverick. However it is possible to do so, by eg installing python2.7 and then setting PYTHONPATH=$PYTHONPATH:/usr/share/pyshared

I then ran

  python2.7 /usr/bin/bzr branch --no-tree http://bazaar.launchpad.net/~jelmer/launchpad/buildd-secret-tokens test3

and

  python2.7 /usr/bin/bzr info https://code.launchpad.net/bzr

but neither of them failed with bzr 2.2.1-0 from unpatched maverick.

Is there some other reproduction recipe I should try? Or could it be that maverick's python2.7 does not have this problem?

So this is not specifically verified, but I don't think it should hold up the SRU MRE of the other fixes either.

John A Meinel (jameinel) wrote :

This doesn't appear to be properly fixed in the 2.2 series. Or at a minimum, I'm unable to reproduce *this* bug because of another bug.

Looking at the Traceback of the bug, it seems to be a mismatch between xmlrpclib and bzr's implementation of the XMLRPCTransport. However, with bzr 2.2.[1,2,3,4,5-dev] I get:

  File "/home/jameinel/dev/bzr/2.2/work/bzrlib/plugins/launchpad/lp_registration.py", line 195, in send_request
    result = method(*method_params)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1570, in __request
    verbose=self.__verbose
  File "/home/jameinel/dev/bzr/2.2/work/bzrlib/plugins/launchpad/lp_registration.py", line 78, in request
    return self.parse_response(response)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1449, in parse_response
    if response.getheader("Content-Encoding", "") == "gzip":
AttributeError: addinfourl instance has no attribute 'getheader'

bzr 2.2.5dev on python 2.7.0 (Linux-2.6.35-28-generic-x86_64-with-Ubuntu-10.10-maverick)

Which indicates that bzr-2.2.* is still incompatible with python2.7.

Note that bzr-2.3 is compatible since about b2.

$ bzr revert -r tag:bzr-2.3b1
$ python2.7 ./bzr info lp:bzr
...
  File "/home/jameinel/dev/bzr/2.3/work/bzrlib/plugins/launchpad/lp_registration.py", line 78, in request
    return self.parse_response(response)
  File "/usr/lib/python2.7/xmlrpclib.py", line 1449, in parse_response
    if response.getheader("Content-Encoding", "") == "gzip":
AttributeError: addinfourl instance has no attribute 'getheader'

bzr 2.3b1 on python 2.7.0 (Linux-2.6.35-28-generic-x86_64-with-Ubuntu-10.10-maverick)

However:
$ bzr revert -r tag:bzr-2.3b2
Repository branch (format: unnamed)
Location:
...

So I consider this "Not Fixed" in 2.2. However, if you look at the traceback, it *is* slightly different. So it is possible that another bug in the 2.2 series python2.7 compatibility is masking the fact that *this* bug was fixed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.2.4-0ubuntu1

---------------
bzr (2.2.4-0ubuntu1) maverick-proposed; urgency=low

  [ Jelmer Vernooij ]
  * Update watch file to use 2.2 series.
  * New upstream release.
   + Fixes closing of leaked sockets to SSH subprocesses, which causes
     dput sftp uploads to hang. LP: #659590
   + Fixes the use of 'lp:' urls behind a http proxy. LP: #558343
   + Correctly sets the Content-Type header when http POSTing to comply
     with stricter web frameworks. LP: #665100
   + Fixes propagating tags to the master branch in a bound branch or
     heavyweight checkout. LP: #603395
   + Fixes the use of 'bzr resolve --take-other' if the file is
     involved in an unresolved text conflict. LP: #646961
   + Fixes https access with newer versions of python2.7. LP: #693880
   + Fixes crash during pack caused by a concurrent repository pack
     operation. LP: #701940
   + Fixes communication with the Launchpad web service when using
     launchpadlib >= 1.5.5. LP: #707075
   + Switches away from deprecated 'edge.launchpad.net' LP: #583667
   + Fixes resolving of content (and path) conflicts for files in subdirs.
     LP: #660935
   + Fixes nasty recursion loop while displaying branch opening error.
     LP: #687653

  [ Martin Pool ]
  * Propose for maverick SRU.
 -- Martin Pool <email address hidden> Thu, 07 Apr 2011 15:30:17 +1000

Changed in bzr (Ubuntu Maverick):
status: Fix Committed → Fix Released
Martin Packman (gz) wrote :

Is there anything left to do on 2.2 here? It's currently flagged as "Incomplete" which is confusing.

Really, anyone who wants to use Python 2.7 with Bazaar should be on at least 2.3 as this was just one of a number of incompatibilities that were fixed on trunk but not backported.

Vincent Ladeuil (vila) wrote :

I agree, we don't plan to put any effort to make 2.2 compatible with 2.7 so there is no point keeping this bug open.

Changed in bzr:
milestone: 2.3b5 → none
Jelmer Vernooij (jelmer) on 2011-10-31
Changed in bzr (Debian):
status: New → Fix Released
assignee: nobody → Jelmer Vernooij (jelmer)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers