"bzr help conflict-types" suggests incorrect "bzr resolve --auto" command line

Bug #688506 reported by Eli Zaretskii
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned
Breezy
Medium
Martin Packman

Bug Description

"bzr help conflict-types" says, under "Text conflicts":

  When you have resolved text conflicts, just run ``bzr resolve --auto``, and
  Bazaar will auto-detect which conflicts you have resolved.

But "bzr resolve" does not accept the --auto switch. The correct command is "bzr resolve", without any switches.

Related branches

Revision history for this message
Vincent Ladeuil (vila) wrote :

Ouch.

There is a FIXME in this code:

                    # FIXME: There is a special case here related to the option
                    # handling that could be clearer and easier to discover by
                    # providing an --auto action (bug #344013 and #383396) and
                    # make it mandatory instead of implicit and active only
                    # when no file_list is provided -- vila 091229
                    action = 'auto'

Looks like the FIXME author and the doc author went out of sync.... ;)

summary: - "bzr help conflict-types" suggests incorrect "bzr resolve" command line
+ "bzr help conflict-types" suggests incorrect "bzr resolve --auto"
+ command line
Changed in bzr:
status: New → Confirmed
tags: added: doc easy
Revision history for this message
Vincent Ladeuil (vila) wrote :

Bad wrapping :-/
# FIXME: There is a special case here related to the option
# handling that could be clearer and easier to discover by
# providing an --auto action (bug #344013 and bug #383396) and
# make it mandatory instead of implicit and active only
# when no file_list is provided -- vila 091229

Revision history for this message
Vincent Ladeuil (vila) wrote :

and bad bug number... that's bug #389396

If only one can edit its own comments....

Jelmer Vernooij (jelmer)
tags: added: check-for-breezy
Jelmer Vernooij (jelmer)
Changed in brz:
status: New → Triaged
importance: Undecided → Medium
tags: added: conflicts
removed: check-for-breezy
Changed in brz:
milestone: none → 3.0.1
Jelmer Vernooij (jelmer)
Changed in brz:
status: Triaged → Fix Committed
assignee: nobody → Martin Packman (gz)
Jelmer Vernooij (jelmer)
Changed in brz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers