"exceptions.OverflowError: long int too large to convert" in _dirstate_helpers_pyx.c

Bug #683191 reported by jorge on 2010-11-30
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Bazaar
Low
Martin Packman
2.4
Low
Martin Packman
bzr (Ubuntu)
Low
Jelmer Vernooij
Oneiric
Low
Jelmer Vernooij

Bug Description

bzr: ERROR: exceptions.OverflowError: long int too large to convert

Traceback (most recent call last):
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py", line 1448, in callable_with_cleanup
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py", line 1616, in _open_location_task
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\location_viewer.py", line 161, in add_location
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\location.py", line 178, in view
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\view_workingtree.py", line 72, in ui
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\html_report_view.py", line 51, in ui
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\html_report_view.py", line 55, in refresh_view
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\view_workingtree.py", line 97, in report_text
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\status_report.py", line 195, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\status_report.py", line 212, in _collect_data
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\status_data.py", line 43, in get_status_info
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\status_data.py", line 61, in changes_between_trees
  File "bzrlib\tree.pyo", line 94, in changes_from
  File "bzrlib\decorators.pyo", line 140, in read_locked
  File "bzrlib\tree.pyo", line 1002, in compare
  File "bzrlib\delta.pyo", line 127, in _compare_trees
  File "_dirstate_helpers_pyx.pyx", line 1439, in bzrlib._dirstate_helpers_pyx.ProcessEntryC.__next__ (bzrlib\_dirstate_helpers_pyx.c:12084)
  File "_dirstate_helpers_pyx.pyx", line 1712, in bzrlib._dirstate_helpers_pyx.ProcessEntryC._iter_next (bzrlib\_dirstate_helpers_pyx.c:14846)
  File "_dirstate_helpers_pyx.pyx", line 1811, in bzrlib._dirstate_helpers_pyx.ProcessEntryC._loop_one_block (bzrlib\_dirstate_helpers_pyx.c:15715)
  File "_dirstate_helpers_pyx.pyx", line 1136, in bzrlib._dirstate_helpers_pyx.ProcessEntryC._process_entry (bzrlib\_dirstate_helpers_pyx.c:8198)
  File "_dirstate_helpers_pyx.pyx", line 872, in bzrlib._dirstate_helpers_pyx._update_entry (bzrlib\_dirstate_helpers_pyx.c:5834)
  File "_dirstate_helpers_pyx.pyx", line 826, in bzrlib._dirstate_helpers_pyx._pack_stat (bzrlib\_dirstate_helpers_pyx.c:5534)
OverflowError: long int too large to convert

bzr 2.3b3 on python 2.6.6 (win32)
arguments: ['C:\\Program Files (x86)\\Bazaar\\bzr.exe', 'explorer']
encoding: 'cp1252', fsenc: 'mbcs', lang: None
plugins:
  bzrtools C:\Program Files (x86)\Bazaar\plugins\bzrtools [2.3.0]
  colo C:\Program Files (x86)\Bazaar\plugins\colo [0.2.1dev]
  explorer C:\Program Files (x86)\Bazaar\plugins\explorer [1.1.2dev]
  fastimport C:\Program Files (x86)\Bazaar\plugins\fastimport [0.10.0dev]
  launchpad C:\Program Files (x86)\Bazaar\plugins\launchpad [2.3b3]
  loom C:\Program Files (x86)\Bazaar\plugins\loom [2.2.1dev]
  netrc_credential_store C:\Program Files (x86)\Bazaar\plugins\netrc_credential_store [2.3b3]
  news_merge C:\Program Files (x86)\Bazaar\plugins\news_merge [2.3b3]
  pipeline C:\Program Files (x86)\Bazaar\plugins\pipeline [unknown]
  qbzr C:\Program Files (x86)\Bazaar\plugins\qbzr [0.20.0dev1]
  rewrite C:\Program Files (x86)\Bazaar\plugins\rewrite [0.6.2dev]
  svn C:\Program Files (x86)\Bazaar\plugins\svn [1.0.5dev]
  upload C:\Program Files (x86)\Bazaar\plugins\upload [1.0.0dev]
  xmloutput C:\Program Files (x86)\Bazaar\plugins\xmloutput [0.8.7.dev]

Related branches

Alexander Belchenko (bialix) wrote :

It looks like the problem in bzr itself.

affects: bzr-explorer → bzr
summary: - Bzr crash on openingn project
+ exceptions.OverflowError: long int too large to convert in
+ _dirstate_helpers_pyx.c

IIUC you're running 64-bit OS?

summary: - exceptions.OverflowError: long int too large to convert in
+ "exceptions.OverflowError: long int too large to convert" in
_dirstate_helpers_pyx.c
Vincent Ladeuil (vila) on 2011-01-04
Changed in bzr:
status: New → Incomplete
Martin Packman (gz) wrote :

From the bug 697867, this appears to involve file bigger than the native long size. See also bug 531612 which is about committing large files.

Changed in bzr:
importance: Undecided → Low
status: Incomplete → Confirmed
Martin Packman (gz) on 2011-09-26
Changed in bzr:
assignee: nobody → Martin Packman (gz)
status: Confirmed → In Progress
Martin Packman (gz) on 2011-09-29
Changed in bzr:
milestone: none → 2.5b2
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2011-11-02
Changed in bzr (Ubuntu):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2011-11-02
Changed in bzr (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in bzr (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Jelmer Vernooij (jelmer)
Martin Pitt (pitti) wrote :

Please update bzr in precise first, as per SRU policy. Otherwise this can't progress into -updates.

Martin Pitt (pitti) wrote :

I don't believe that this is fixed in precise:
       bzr | 2.4.1-1ubuntu1 | oneiric | source, all
       bzr | 2.4.1-1ubuntu1 | precise | source, all

Changed in bzr (Ubuntu):
status: Fix Released → In Progress
Changed in bzr (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed

Hello jorge, or anyone else affected,

Accepted bzr into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.5.0~beta2-0ubuntu1

---------------
bzr (2.5.0~beta2-0ubuntu1) precise; urgency=low

  * New upstream release.
   + Fixes compatibility with cython 0.15. LP: #837221
   + Fixes handling of timestamps in diffs for absent files in working tree.
     LP: #847435
   + Fixes overflow error in dirstate when dealing with large files.
     LP: #683191
  * Merge from Debian. Remaining changes:
   + Drop build dependencies on python-{subunit,meliae,lzma,medusa}, which are
     not in main.
   + Disable support for running selftest in parallel (requires subunit).
 -- Jelmer Vernooij <email address hidden> Fri, 04 Nov 2011 22:55:11 +0100

Changed in bzr (Ubuntu):
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-08
Changed in bzr (Ubuntu Oneiric):
status: Fix Committed → Fix Released

The fix for this bug has been awaiting testing feedback in the -proposed repository for oneiric for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

Changed in bzr (Ubuntu Oneiric):
status: Fix Released → Fix Committed
tags: added: removal-candidate
Martin Packman (gz) wrote :

Per bug 837221 comment 7 I've verified the package in proposed passes the relevent tests in the integrated test suite.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.4.2-0ubuntu1

---------------
bzr (2.4.2-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
   + Fix OverflowError in _dirstate_helpers_pyx.c. LP: #683191
   + Fix compatibility with Cython 0.15. LP: #837221
 -- Jelmer Vernooij <email address hidden> Wed, 02 Nov 2011 15:01:08 +0100

Changed in bzr (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers