wishlist: bzr pull --overwrite-tags

Bug #681792 reported by Gary van der Merwe
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar
Fix Released
High
Jelmer Vernooij
bzr (Ubuntu)
Fix Released
High
Jelmer Vernooij

Bug Description

I had 2 branches with conflicting tag. I then did a bzr pull --overwrite to get the tags is sync, but then lost revisions that were only in the branch I was pulling to.

I was able to recover the revisions using bzr heads --dead, but it was a unpleasing user experience.

It would be nice if one could do something like bzr pull --overwrite-tags

Tags: easy tags ui

Related branches

Revision history for this message
Andrew Bennetts (spiv) wrote :

Sounds reasonable to me.

Changed in bzr:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: easy tags ui
Martin Pool (mbp)
Changed in bzr:
importance: Wishlist → Undecided
importance: Undecided → Medium
Martin Pool (mbp)
Changed in bzr:
status: Confirmed → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

This bug is affecting the tool from the Go language that downloads remote packages from Bazaar branches. Go uses tags as a way to relate a specific revision in the branch to a given version of the compiler suite, so every once in a while such tags have to be updated to point to a new version of the branch's code. Then, once one says something like "go get -u launchpad.net/mgo", the tool will attempt to update the local version of the package, but since tags are often updated, it currently has to use --overwrite as well, which is not great.

Having a --overwrite-tags flag is exactly what would be needed in that case.

Revision history for this message
Jelmer Vernooij (jelmer) wrote :

This shouldn't actually be a lot of additional work to finish, so let's JFDI.

Changed in bzr:
importance: Medium → High
milestone: none → 2.5.0
Vincent Ladeuil (vila)
Changed in bzr:
milestone: 2.5.0 → 2.5b6
Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

Just to be clear, push has the same issue as well. Is the intention to add the flag on both push and pull?

Revision history for this message
Martin Pool (mbp) wrote : Re: [Bug 681792] Re: wishlist: bzr pull --overwrite-tags

On 1 February 2012 06:45, Gustavo Niemeyer <email address hidden> wrote:

> Just to be clear, push has the same issue as well. Is the intention to
> add the flag on both push and pull?
>

I would think so.

--
Martin

Revision history for this message
Jelmer Vernooij (jelmer) wrote :

On Tue, Jan 31, 2012 at 09:49:17PM -0000, Martin Pool wrote:
> On 1 February 2012 06:45, Gustavo Niemeyer <email address hidden> wrote:
>
> > Just to be clear, push has the same issue as well. Is the intention to
> > add the flag on both push and pull?
> I would think so.
Yeah. It's going to require a slight API change, so I'm looking at
landing it before beta 6 this Thursday.

Cheers,

Jelmer

Revision history for this message
Jelmer Vernooij (jelmer) wrote :

On 01/31/2012 08:45 PM, Gustavo Niemeyer wrote:
> Just to be clear, push has the same issue as well. Is the intention to
> add the flag on both push and pull?
Yes. They're pretty similar in the codebase. My existing branch already
does this for both push and pull.

Vincent Ladeuil (vila)
Changed in bzr:
milestone: 2.5b6 → 2.5.0
Vincent Ladeuil (vila)
Changed in bzr:
milestone: 2.5.0 → none
Revision history for this message
Gustavo Niemeyer (niemeyer) wrote :

Is this being dropped from 2.5?

Revision history for this message
Jelmer Vernooij (jelmer) wrote :

Yes, it didn't make it into 2.5.0 because of concerns about API changes so late in the cycle. See https://code.launchpad.net/~jelmer/bzr/overwrite-tags/+merge/91277 for the discussion.

Sorry for not letting you know about this earlier; after the discussion on the merge proposal I got distracted by other things and then forgot about it.

There are still some things we can do, such as providing a plugin with a command that implements this behaviour. Would that help, or are there perhaps other things we can do?

Jelmer Vernooij (jelmer)
Changed in bzr:
status: In Progress → Fix Released
milestone: none → 2.6b2
Jelmer Vernooij (jelmer)
Changed in bzr (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer)
Changed in bzr (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers