Make bzr revno --tree available without net access on lightweight checkouts

Bug #672330 reported by Christian Faulhammer on 2010-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Wishlist
Unassigned
Gentoo Linux
Fix Released
Wishlist

Bug Description

In Gentoo we use lightweight checkouts for live ebuilds (aka build from the repository head and have it installed under the control of our package manager). For an additional tool we check for the state of the last checkout and want to access the revision number, which is not a problem when having internet access, but we want to be able to do that without any access there. For a non-lightweight checkout the revision is stored in .bzr/branch/last-revision which is a tiny file, one line of text only, maybe this could be provided for the lightweight version, too.
Thanks in advance for the work.

John A Meinel (jameinel) wrote :

It isn't really trivial, since it would require a disk format change. But it is something we could consider.

Note that at present, doing *any* operation on a lightweight checkout will always connect to its associated branch (even if it could be answered from the checkout itself). (I think there is an open wishlist bug to avoid that as well)

Changed in bzr:
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gentoo:
status: Unknown → Fix Released
Changed in gentoo:
importance: Unknown → Wishlist
Changed in gentoo:
status: Fix Released → Confirmed
Changed in gentoo:
status: Confirmed → Fix Released
Jelmer Vernooij (jelmer) on 2017-11-09
tags: added: check-for-breezy
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.