syntax error doesn't prevent merge

Bug #626667 reported by Vincent Ladeuil on 2010-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Vincent Ladeuil

Bug Description

It looks like a recent submission of mine got accepted while a syntax error was present.
This may be specific to the bzr pqm instance though.

The bzr revid is: <email address hidden>

Vincent Ladeuil (vila) on 2010-08-30
Changed in pqm:
status: New → Confirmed
importance: Undecided → Critical
Vincent Ladeuil (vila) wrote :

Submitting a fix for the syntax error woke up pqm a bit and I was able to capture:

PQM Queue: 1 scripts

Current time: Mon, 30 Aug 2010 08:32:52 UTC
Now playing...

plugins:
  bash_completion /home/pqm/bzr-pqm-workdir/home/+trunk/bzrlib/plugins/bash_completion [2.3.0dev1]
  launchpad /home/pqm/bzr-pqm-workdir/home/+trunk/bzrlib/plugins/launchpad [2.3.0dev1]
  netrc_credential_store /home/pqm/bzr-pqm-workdir/home/+trunk/bzrlib/plugins/netrc_credential_store [2.3.0dev1]
  news_merge /home/pqm/bzr-pqm-workdir/home/+trunk/bzrlib/plugins/news_merge [2.3.0dev1]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.
success: merge http://bazaar.launchpad.net/~vila/bzr/integration2/ http://bazaar.launchpad.net/~bzr-pqm/bzr/bzr.dev
Finished [ 0% ]

    *

      Mon Aug 30 08:32:11 2010 UTC: Vincent Ladeuil <email address hidden>, '(vila) Fix a python-2.[45] syntax error in previous submission (lockable config files) (Vincent Ladeuil)'
         1. Merge http://bazaar.launchpad.net/~vila/bzr/integration/ http://bazaar.launchpad.net/~bzr-pqm/bzr/bzr.dev

Vincent Ladeuil (vila) wrote :

Ok, PQM is innocent, the bug comes from the bzr Makefile:

 check-nodocs: extensions
  # Generate a stream for PQM to watch
  $(PYTHON) -Werror -O ./bzr selftest --subunit $(tests) | tee selftest.log
  # Check that there were no errors reported.
  subunit-stats < selftest.log

The '|' makes the shell action succeeds because 'tee' succeeds, masking the error in the first command.

I'll submit a patch.

affects: pqm → bzr
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
status: Confirmed → In Progress
Martin Pool (mbp) on 2010-08-31
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers