Re: 'module' object has no attribute 'TIOCGWINSZ'

Bug #62539 reported by Robert Collins on 2006-09-27
4
Affects Status Importance Assigned to Milestone
Bazaar
Low
Vincent Ladeuil

Bug Description

On Tue, 2006-09-19 at 16:02 -0600, Andrew McNabb wrote:
> Hey. I'm just following orders ("** please send this report to
> <email address hidden>"). Here's my traceback, after doing a "bzr
> checkout" on an IRIX 6.5 box:
>
> bzr: ERROR: <type 'exceptions.AttributeError'>: 'module' object has no attribute 'TIOCGWINSZ'
> ...
> x = fcntl.ioctl(1, termios.TIOCGWINSZ, s)
> AttributeError: 'module' object has no attribute 'TIOCGWINSZ'
>
> bzr 0.10.0 on python 2.5.0.final.0 (irix6)
> arguments: ['/fsc/awm27/bin/bzr', 'checkout', 'sftp://provo.mcnabbs.org//repos']

Looks like TIOCGWINSZ is not always available. We should make this safe
via a three-param getattr call.

I'm filing this as a bug report.

 affects /products/bzr

--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

Related branches

This is a trivial fix, so lets do it for 0.12

Changed in bzr:
importance: Undecided → Low
status: Unconfirmed → Confirmed
John A Meinel (jameinel) wrote :

missed 0.12, is simple enough to happen soon.

Vincent Ladeuil (vila) on 2009-10-23
Changed in bzr:
milestone: 0.13 → none
assignee: nobody → Vincent Ladeuil (vila)
status: Confirmed → In Progress
Vincent Ladeuil (vila) wrote :

Addressed while fixing bug #353370.

Changed in bzr:
assignee: Vincent Ladeuil (vila) → nobody
status: In Progress → Fix Committed
Vincent Ladeuil (vila) on 2009-12-04
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
milestone: none → 2.1.0b4
Vincent Ladeuil (vila) on 2009-12-04
Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers