progress bar does not clear correctly

Bug #611127 reported by Parth Malwankar on 2010-07-29
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Martin Pool

Bug Description

While doing a standalone branch of bzr trunk I noticed that the progress bar does not clear correctly.

[tmp]% time bzr branch ~/src/bzr.dev/trunk trunk0 > /dev/null
\ Fetching revisions:Inserting missing keys:28549/3285498549

3285498549 should actually be 328549. Thats what it starts of with but when the text content gets shorter the right edge doesn't get cleared.

With the overlap produced by the "adding file" phase this finally becomes:

[tmp]% time bzr branch ~/src/bzr.dev/trunk trunk0 > /dev/null
Branched 5361 revision(s).adding file 0/421428549/3285498549

Parth Malwankar (parthm) on 2010-07-29
tags: added: confusing-ui ui
tags: added: progress
tags: removed: confusing-ui ui
Changed in bzr:
status: New → Confirmed
importance: Undecided → Medium
Martin Pool (mbp) wrote :

This is probably a regression caused by my change in the last couple of weeks :/

Max Bowsher (maxb) wrote :

Definitely a regression vs 2.1. Here's another example:

maxb@z61p:~/wc/bzr/bzr/2.2$ bzr pull
Using saved parent location: bzr+ssh://bazaar.launchpad.net/~bzr-pqm/bzr/2.2/
No revisions to pull.Fetching revisions:Finishing stream
maxb@z61p:~/wc/bzr/bzr/2.2$

tags: added: regression
Martin Pool (mbp) on 2010-08-05
Changed in bzr:
assignee: nobody → Martin Pool (mbp)
importance: Medium → High
milestone: none → 2.2.0
status: Confirmed → In Progress
John A Meinel (jameinel) on 2010-08-06
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers