permission denied on smbfs where unix mode bits can't be set

Bug #606537 reported by acornblue on 2010-07-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Martin Pool

Bug Description

tried creating a shared repo on /media/boxj. boxj is mounted with smbfs. i believe it is running win server 2010.

uname -a Linux ubuntu10 2.6.32-23-generic #37-Ubuntu SMP Fri Jun 11 07:54:58 UTC 2010 i686 GNU/Linux

Fri 2010-07-16 17:22:44 -0700
0.128 bazaar version: 2.1.1
0.129 bzr arguments: [u'init-repo', u'--no-trees', u'-D', u'repo']
0.171 looking for plugins in /home/ubuntu10/.bazaar/plugins
0.181 looking for plugins in /usr/lib/python2.6/dist-packages/bzrlib/plugins
0.349 encoding stdout as sys.stdout encoding 'UTF-8'
0.451 Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 853, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 1055, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 661, in run_argv_aliases
    return self.run_direct(**all_cmd_args)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 665, in run_direct
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 122, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 156, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/builtins.py", line 1819, in run
    newdir = format.initialize_on_transport(to_transport)
  File "/usr/lib/python2.6/dist-packages/bzrlib/bzrdir.py", line 1886, in initialize_on_transport
    return self._initialize_on_transport_vfs(transport)
  File "/usr/lib/python2.6/dist-packages/bzrlib/bzrdir.py", line 2007, in _initialize_on_transport_vfs
    mode=temp_control._dir_mode)
  File "/usr/lib/python2.6/dist-packages/bzrlib/transport/local.py", line 325, in mkdir
    self._mkdir(self._abspath(relpath), mode=mode)
  File "/usr/lib/python2.6/dist-packages/bzrlib/transport/local.py", line 321, in _mkdir
    self._translate_error(e, abspath)
  File "/usr/lib/python2.6/dist-packages/bzrlib/transport/__init__.py", line 318, in _translate_error
    raise errors.PermissionDenied(path, extra=e)
PermissionDenied: Permission denied: "/media/boxj/2010/repo/.bzr": [Errno 13] Permission denied: '/media/boxj/2010/repo/.bzr'

0.452 Transferred: 0KiB (0.0K/s r:0K w:0K)
0.452 return code 3

Related branches

Martin Pool (mbp) on 2010-07-19
Changed in bzr:
status: New → Invalid
Martin Pool (mbp) on 2010-07-20
Changed in bzr:
status: Invalid → Confirmed
summary: - [Errno 13] Permission denied
+ permission denied on smbfs where unix mode bits can't be set
Changed in bzr:
importance: Undecided → Medium
acornblue (acornblue) wrote :

Would it be possible to push the importance higher since there is no workaround and the error should be more a warning...

Jelmer Vernooij (jelmer) on 2011-02-01
tags: added: filesystem smbfs
Martin Pool (mbp) on 2011-11-14
Changed in bzr:
status: Confirmed → In Progress
assignee: nobody → Martin Pool (mbp)
Martin Pool (mbp) wrote :

hi, all,

there is an attempted workaround for this in lp:~mbp/bzr/606537-mkdir

if you could try running bzr from there and let me know if it does in fact fix it in your environment, that would be great.

Martin Pool (mbp) on 2011-11-18
Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers