'bzr ignore' undocumented behaviour and misleading tutorial

Bug #59608 reported by David Roberts on 2006-09-09
2
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Patrick Regan

Bug Description

From observation of behaviour, not by reading code, it is apparent that 'ignore' creates a .bzrignore file if none exists, or appends to it if it exists already. That might be expected. 'ignore' ALSO does an implicit and silent ADD of .bzrignore to the versioned file set. That was not entirely expected, and the tutorial is misleading in this respect.

The section headed 'Ignoring files' does not mention 'bzr ignore', but explicitly gives an examples of 'bzr add .bzrignore' . This user spent [wasted?] sometime trying to work out why the ADD operation never reported that the file was added. It's because it had already been versioned automagically, so the command was redundant!

Suggest clarifying/updating tutorial, and consider adding reporting code to 'bzr ignore' to say 'Created .bzrignore and made it versioned.'

Tags: doc Edit Tag help

Related branches

John A Meinel (jameinel) wrote :

Agreed, the tutorial should be updated for stuff like this.

Changed in bzr:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in bzr:
status: Confirmed → In Progress
assignee: nobody → Patrick Regan (patrick-regan)
Changed in bzr:
status: In Progress → Fix Committed
Ian Clatworthy (ian-clatworthy) wrote :

This can actually be marked as "Fix Released". See http://doc.bazaar-vcs.org/developers/bug-handling.html for details but, basically, landed in trunk == Fix Released by our conventions.

Changed in bzr:
milestone: none → 2.1.0b4
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers