doc should describe how to create a case-insensitive ignore pattern

Bug #594386 reported by Martin Pool on 2010-06-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Parth Malwankar

Bug Description

You can use "RE:(?i)foo" but this is not very obvious.

As a followon we could perhaps add a zsh-style option (or something else) for a case-insensitive glob.

Related branches

Martin Pool (mbp) on 2010-06-14
tags: added: doc easy
Changed in bzr:
importance: Undecided → Medium
status: New → Confirmed
Vincent Ladeuil (vila) wrote :

For consistency, I'd prefer that we stick on python RE:, I understand the ease-of-use wish here, but
I feel that this should be better addressed by a good documentation than by adding lots of specifics
in the glob handling (globs are limited by design anyway).

Martin Pool (mbp) wrote :

On 15 June 2010 11:27, Robert Collins <email address hidden> wrote:
> For clarity, what is a zsh style ... ?

(#I)readme

(capital I) matches case insensitively.

http://manpages.ubuntu.com/manpages/lucid/en/man1/zshexpn.1.html

--
Martin

Parth Malwankar (parthm) on 2010-07-08
Changed in bzr:
assignee: nobody → Parth Malwankar (parthm)
John A Meinel (jameinel) on 2010-08-06
Changed in bzr:
milestone: none → 2.2.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers