bzr talks to edge API servers to propose merges (but not for lp: url lookups)

Bug #583667 reported by Robert Collins on 2010-05-21
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil
2.0
High
Vincent Ladeuil
2.1
High
Vincent Ladeuil
2.2
High
Vincent Ladeuil
2.3
High
Vincent Ladeuil
bzr (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

bzr lp-propose talks to Launchpad's edge servers, which are deprecated[1] and may eventually be removed. It ought to talk to lpnet instead.

[1] http://blog.launchpad.net/general/edge-is-deprecated

Related branches

summary: - bzr talks to edge API servers to propose merges etc
+ bzr talks to edge API servers to propose merges (but not for lp: url
+ lookups)
Robert Collins (lifeless) wrote :

Also, we should fix bug 583673 at the same time, to avoid giving our users a rough time.

Changed in bzr:
importance: Wishlist → High
Vincent Ladeuil (vila) wrote :

@lifeless: What's the status here ?

Do we still need to use the edge servers until they die or can we already stop using them ?

If I read http://blog.launchpad.net/general/edge-is-deprecated correctly we should stop but I'm not sure I understand *this* bug correctly.

You should switch to LPNET_SERVICE_ROOT as soon as possible. Ideally
you'd do point releases to ensure that all versions 'out there' have
this update made to them.

Thanks,
Rob

Martin Pool (mbp) on 2010-11-26
Changed in bzr:
milestone: none → 2.3.0
Martin Pool (mbp) wrote :

The blog points out that this may actually be cut off on the server side, rather than it just being nice to migrate. When that happens, lp: urls will break for anyone still using old clients.

So we should of course do this in new releases, but it may be hard to reach everyone using old bzrs, and it will be a bad situation if access to lp: branches breaks. (Though not impossible to work around.)

 * there are some supported Ubuntu releases (primarily hardy) holding bzr releases for which there is no stable series
 * not everybody installs -updates
 * we're ending support for the 2.0 series soon, and weren't going to do non-critical updates
 * the SRU process is pretty slow and conservative

It would be awfully nice if there was some way to keep supporting it on the server, but I guess we should merge this into 2.0 at least.

Vincent Ladeuil (vila) wrote :

Exactly my thoughts, I'll target 2.0 and merge up, this won't change our release policy, but given that's a change in a server outside of bzr control, bzr users will need to upgrade anyway one way or the other.

Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
assignee: Vincent Ladeuil (vila) → nobody
Vincent Ladeuil (vila) on 2010-11-26
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2010-12-03
Changed in bzr:
milestone: 2.3.0 → none
status: Confirmed → Fix Released
Jelmer Vernooij (jelmer) on 2011-01-28
Changed in bzr (Ubuntu):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2011-03-13
Changed in bzr (Ubuntu):
status: Confirmed → Fix Released

Accepted bzr into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bzr (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Martin Pool (mbp) wrote :

This was already fixed in the first release of maverick.

Changed in bzr (Ubuntu Maverick):
status: Fix Committed → Fix Released
status: Fix Released → In Progress
description: updated
Martin Pool (mbp) wrote :

Please ignore my previous comment about it being fixed. I posted to the wrong bug tab.

Verification:

In a maverick chroot, I set

0.0.0.0 api.edge.launchpad.net xmlrpc.edge.launchpad.net

into /etc/hosts, and then tried 'bzr lp-propose' on a branch. With 2.2.0-1, I get invited to make an edge api token. With 2.2.4-0ubunt1 from maverick-proposed, my existing lpnet token is used, and it correctly reports

bzr: ERROR: There is already a branch merge proposal: https://code.launchpad.net/~mbp/bzr/progress/+merge/58627

So I conclude 2.2.4 is indeed correctly using lpnet not edge.

verified ok.

tags: added: verification-ok
removed: verification-needed
Martin Pool (mbp) on 2011-04-21
tags: added: verification-done
removed: verification-ok
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.2.4-0ubuntu1

---------------
bzr (2.2.4-0ubuntu1) maverick-proposed; urgency=low

  [ Jelmer Vernooij ]
  * Update watch file to use 2.2 series.
  * New upstream release.
   + Fixes closing of leaked sockets to SSH subprocesses, which causes
     dput sftp uploads to hang. LP: #659590
   + Fixes the use of 'lp:' urls behind a http proxy. LP: #558343
   + Correctly sets the Content-Type header when http POSTing to comply
     with stricter web frameworks. LP: #665100
   + Fixes propagating tags to the master branch in a bound branch or
     heavyweight checkout. LP: #603395
   + Fixes the use of 'bzr resolve --take-other' if the file is
     involved in an unresolved text conflict. LP: #646961
   + Fixes https access with newer versions of python2.7. LP: #693880
   + Fixes crash during pack caused by a concurrent repository pack
     operation. LP: #701940
   + Fixes communication with the Launchpad web service when using
     launchpadlib >= 1.5.5. LP: #707075
   + Switches away from deprecated 'edge.launchpad.net' LP: #583667
   + Fixes resolving of content (and path) conflicts for files in subdirs.
     LP: #660935
   + Fixes nasty recursion loop while displaying branch opening error.
     LP: #687653

  [ Martin Pool ]
  * Propose for maverick SRU.
 -- Martin Pool <email address hidden> Thu, 07 Apr 2011 15:30:17 +1000

Changed in bzr (Ubuntu Maverick):
status: In Progress → Fix Released
Clint Byrum (clint-fewbar) wrote :

Accepted bzr into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bzr (Ubuntu Lucid):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Martin Pool (mbp) wrote :

per https://wiki.ubuntu.com/StableReleaseUpdates/MicroReleaseExceptions we're not going to do bug-by-bug verification, but we will get some people to do smoke testing to check there are no regressions

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.1.4-0ubuntu1

---------------
bzr (2.1.4-0ubuntu1) lucid-proposed; urgency=low

  * Update watch file to use 2.1 series.
  * New upstream release.
   + Fix file descriptors leaks in dirstate compiled extension. LP: #583486
   + Refuse to stack on repositories in incompatible formats. LP: #562380
   + Don't delete nested trees/repos. LP: #572098
   + Fix 'bzr switch' crash when a 'ConfigurableFileMerger' is used. LP: #559436
   + Fix compatibility with older smart servers. LP: #528041
   + Fix symlinks addition. LP: #192859
   + Properly unversion children of unversioned directories. LP: #494221
   + Lock configuration files in '~/.bazaar' for updates. LP: #525571
   + Fix 'bzr commit <symlink>'. LP: #128562
   + Fix `lp:` urls when behind an http proxy. LP: #558343
   + Stop using edge.launchpad.net. LP: #583667
 -- Max Bowsher <email address hidden> Tue, 17 May 2011 09:54:17 +0100

Changed in bzr (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers