test_get_unknown_file fails for pycurl if curl was compiled against gnutls

Bug #568421 reported by Martin von Gagern on 2010-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Vincent Ladeuil

Bug Description

Running the selftest suite on a Gentoo system with curl compiled against gnutls, the test_get_unknown_file and test_get_bytes_unknown_file tests fail as attached. Dunno if this is a bug in the test server, in pycurl, in gnutls, or whatever.

Wireshark lists what seems a proper connection setup, then some app data, then the client sending an ACK to the server, and sending an "Encrypted Alert" to the server next, to which the server responds with a RST.

Haven't managed to sniff the encrypted traffic yet, and I'm not sure I will.

Related branches

Martin von Gagern (gagern) wrote :
Vincent Ladeuil (vila) wrote :

It's most likely due to a bug in gnutls/curl even if the provided trace is not enough to be conclusive here.

Keep in mind that the long term plan for bzr is to add certificated verification (and may be also NTLM support) to the urllib http client and deprecate pycurl support (see bug #125055 and https://answers.edge.launchpad.net/bzr/+faq/590)

I'll mark the bug incomplete as little can be done without a better understanding about why GnuTLS fails to return a 404 error.

Changed in bzr:
importance: Undecided → Low
status: New → Incomplete
Vincent Ladeuil (vila) wrote :

I can reproduce the exact same bug on a fresh maverick install, with bzr.dev and python-2.6.

Changed in bzr:
importance: Low → Medium
status: Incomplete → Confirmed
Vincent Ladeuil (vila) on 2010-07-20
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2010-07-20
Changed in bzr:
milestone: none → 2.2.0
Vincent Ladeuil (vila) wrote :

For the record, the trick I used to better diagnose this was to run:

  ./bzr selftest -s bzrlib.tests.per_transport.TransportTests.test_get_ unknown.*pycurl -Eallow_debug -Dhttp

which run only the failing tests and give some http debug output.

John A Meinel (jameinel) wrote :

The associated branch was merged, so I'm marking this as fixed.

Changed in bzr:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments