crash on bzr+ssh with version 1.5

Bug #551689 reported by sabik on 2010-03-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned

Bug Description

After upgrading client-side to the Lucid beta, bzr crashes on pushing to an older (Debian stable) server using bzr+ssh. The same setup worked (and still works) from Karmic.

client version: Ubuntu bzr 2.1.1-1
server version: Debian bzr 1.5-1.1

~/projekty$ bzr push bzr+ssh://pmj.baum.com.au/achernar/projekty/
Server does not understand Bazaar network protocol 3, reconnecting. (Upgrade the server to avoid this.)
bzr: ERROR: exceptions.AssertionError: _remember_remote_is_before((2, 1)) called, but _remember_remote_is_before((1, 6)) was called previously.

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    attaching the crash file
        /home/jiri/.cache/crash/bzr-20100330132835-18521.crash
    and including a description of the problem.

    The crash file is plain text and you can inspect or edit it to remove
    private information.
~/projekty$

sabik (sabik) wrote :
sabik (sabik) wrote :

Ahh, sorry, should've searched more before reporting it again.

Bug #528041 also has a work-around, which works for me (use "nosmart+bzr+ssh" instead of "bzr+ssh").

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers