ConfigurableFileMerger does not support merging with this_tree a revision tree

Bug #537041 reported by William Grant on 2010-03-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Unassigned

Bug Description

A 'bzr pump' with bzr 2.1.0 and bzr-pipeline 2.1 r157 fails like this:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 853, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 1055, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 661, in run_argv_aliases
    return self.run_direct(**all_cmd_args)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 665, in run_direct
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 122, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 156, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/home/wgrant/.bazaar/plugins/pipeline/commands.py", line 296, in run
    if not manager.pipeline_merge(tree, from_submit):
  File "/home/wgrant/.bazaar/plugins/pipeline/pipeline.py", line 737, in pipeline_merge
    if self._merge_commit(tree, new_branch, old_branch) != []:
  File "/home/wgrant/.bazaar/plugins/pipeline/pipeline.py", line 717, in _merge_commit
    if self._merge_commit_branch(new_branch, old_branch):
  File "/home/wgrant/.bazaar/plugins/pipeline/pipeline.py", line 658, in _merge_commit_branch
    tt = merger.make_preview_transform()
  File "/usr/lib/python2.6/dist-packages/bzrlib/merge.py", line 788, in make_preview_transform
    return operation.run_simple()
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 122, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 156, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/merge.py", line 793, in _make_preview_transform
    self._compute_transform()
  File "/usr/lib/python2.6/dist-packages/bzrlib/merge.py", line 814, in _compute_transform
    file_status = self._do_merge_contents(file_id)
  File "/usr/lib/python2.6/dist-packages/bzrlib/merge.py", line 1302, in _do_merge_contents
    hook_status, lines = hook.merge_contents(params)
  File "/usr/lib/python2.6/dist-packages/bzrlib/merge.py", line 161, in merge_contents
    not self.filename_matches_config(params)):
  File "/usr/lib/python2.6/dist-packages/bzrlib/merge.py", line 133, in filename_matches_config
    config = self.merger.this_tree.branch.get_config()
AttributeError: 'RevisionTree' object has no attribute 'branch'

William Grant (wgrant) wrote :

MergeHooks:
  merge_file_content:
    NEWS file merge

Andrew Bennetts (spiv) wrote :

Looks like something we should fix for 2.1.1.

Changed in bzr:
importance: Undecided → High
milestone: none → 2.1.1
status: New → Confirmed
Vincent Ladeuil (vila) on 2010-04-07
Changed in bzr:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers