apport complains "This problem report applies to a program which is not installed any more."

Bug #528114 reported by Martin Pool on 2010-02-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Unassigned

Bug Description

Greg reports in 528041 that

[note: I tried to have apport submit the .crash file, but it gave me a "This problem report applies to a program which is not installed any more." error, obviously wrong]

The crash file is http://launchpadlibrarian.net/39791527/bzr-20100225212026-7073.crash and it does seem to show that bzr is installed into the locations it would have from a packaged version

Related branches

Martin Pool (mbp) wrote :

Greg, is this using lucid's version of bzr?

description: updated

Yes, Lucid. And I'm not using any PPA for bzr.

Thanks for opening this bug for me, Martin.

James Westby (james-w) wrote :

The issue here is that ExecutablePath is not included in the report, but I can't
see how it avoids adding that.

Thanks,

James

Martin Pool (mbp) wrote :

Thanks for identifying the problem, james_w: we aren't calling add_proc_info and quite a lot of other things in apport do rely on it being there.

Changed in bzr:
status: Confirmed → In Progress
Martin Pool (mbp) wrote :

It turns out you get the same error if SourcePackage and Package are not set.

Martin Pool (mbp) wrote :

This is fixed in 2.2b2.

Changed in bzr:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers