`bzr pull' and `bzr checkout' die with AssertionError

Bug #527960 reported by Gunnar Wolf on 2010-02-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned

Bug Description

When trying to pull from our repository, I get the following error:

Using saved parent location: bzr+ssh://(…)/(…)/
Server does not understand Bazaar network protocol 3, reconnecting. (Upgrade the server to avoid this.)
bzr: ERROR: exceptions.AssertionError: _remember_remote_is_before((2, 1)) called, but _remember_remote_is_before((1, 6)) was called previously.

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 853, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 1055, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 661, in run_argv_aliases
    return self.run_direct(**all_cmd_args)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 665, in run_direct
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/cleanup.py", line 122, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/cleanup.py", line 156, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/builtins.py", line 993, in run
    possible_transports=possible_transports)
  File "/usr/lib/python2.5/site-packages/bzrlib/branch.py", line 169, in open
    possible_transports=possible_transports)
  File "/usr/lib/python2.5/site-packages/bzrlib/bzrdir.py", line 843, in open
    return BzrDir.open_from_transport(t, _unsupported=_unsupported)
  File "/usr/lib/python2.5/site-packages/bzrlib/bzrdir.py", line 878, in open_from_transport
    return format.open(transport, _found=True)
  File "/usr/lib/python2.5/site-packages/bzrlib/bzrdir.py", line 2088, in open
    return self._open(transport)
  File "/usr/lib/python2.5/site-packages/bzrlib/bzrdir.py", line 3327, in _open
    return remote.RemoteBzrDir(transport, self)
  File "/usr/lib/python2.5/site-packages/bzrlib/remote.py", line 115, in __init__
    self._probe_bzrdir()
  File "/usr/lib/python2.5/site-packages/bzrlib/remote.py", line 130, in _probe_bzrdir
    medium._remember_remote_is_before((2, 1))
  File "/usr/lib/python2.5/site-packages/bzrlib/smart/medium.py", line 615, in _remember_remote_is_before
    % (version_tuple, self._remote_version_is_before))
AssertionError: _remember_remote_is_before((2, 1)) called, but _remember_remote_is_before((1, 6)) was called previously.

bzr 2.1.0 on python 2.5.5 (Linux-2.6.32-trunk-vserver-amd64-x86_64-with-debian-squeeze-sid)
arguments: ['/usr/bin/bzr', 'pull']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_US.UTF-8'
plugins:
  bzrtools /usr/lib/python2.5/site-packages/bzrlib/plugins/bzrtools [2.1.0]
  dbus /usr/lib/python2.5/site-packages/bzrlib/plugins/dbus [0.1.0dev]
  explorer /usr/lib/python2.5/site-packages/bzrlib/plugins/explorer [1.0.0b1]
  gtk /usr/lib/python2.5/site-packages/bzrlib/plugins/gtk [0.98.0dev1]
  launchpad /usr/lib/python2.5/site-packages/bzrlib/plugins/launchpad [2.1.0]
  netrc_credential_store /usr/lib/python2.5/site-packages/bzrlib/plugins/netrc_credential_store [2.1.0]
  news_merge /usr/lib/python2.5/site-packages/bzrlib/plugins/news_merge [2.1.0]
  qbzr /usr/lib/python2.5/site-packages/bzrlib/plugins/qbzr [0.18.2]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

I tried to do a fresh checkout (and light-checkout) of the tree, but got the same error.

This might be a compatibility problem between versions - I can correctly check out the repoistory from the server where it resides (bzr 1.5-1.1, Debian 5.0.4, while at my desktop I have bzr 2.1.0-1, Debian unstable), both with file:/// and bzr+ssh:// schemes, but not from the 2.1.0 machine.

Mark (praseodym) wrote :

Same problem here with bzr 1.5 from Debian stable on as server and bzr 2.1 from easy_install on my desktop. Since it is a production server I cannot simply upgrade to an unstable Debian release.

Martin Pool (mbp) wrote :

Mark, you should be able to work around this by prepending 'nosmart+' to the url eg

nosmart+bzr+ssh://example.com.../

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers