--strict should default to warning the user

Bug #519319 reported by Jelmer Vernooij on 2010-02-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Low
Vincent Ladeuil

Bug Description

  affects bzr
  status confirmed
  importance low
  subscribe

Filing a bug for this, as I don't have time to look at it at the moment.

-------- Forwarded Message --------
From: Martin Pool <email address hidden>
To: Jelmer Vernooij <email address hidden>
Cc: <email address hidden>
Subject: Re: --strict as default
Date: Fri, 15 Jan 2010 10:23:18 +1100

2010/1/15 Jelmer Vernooij <email address hidden>:
> At the moment there are several commands that default to --strict. While
> it seems to be a good idea to make the user aware of uncommitted changes
> by default, I think it should be a warning rather than an error by
> default. Most people I've talked to also seem to prefer no-strict by
> default.

I agree. A patch to change it back for 2.1 would be welcome.

Eventually we may want error/warn/nothing, as checking whether there
are uncommitted changes might take nonnegligible time.

Related branches

Vincent Ladeuil (vila) on 2010-04-12
summary: - [Fwd: Re: --strict as default]
+ --strict should default to warning the user
tags: added: dpush push send
Vincent Ladeuil (vila) on 2010-04-12
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2010-04-12
Changed in bzr:
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2010-04-16
Changed in bzr:
milestone: none → 2.2b2
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers