progress bar is not removed when bzr exits

Bug #515569 reported by Alexander Belchenko on 2010-02-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Robert Collins

Bug Description

C:\>bzr tags -d bzr://acad/branches/Main/ChainedFifo/trunk/
/ 2KB 0KB/s |

C:\>bzr version
Bazaar (bzr) 2.1.0rc1
  Python interpreter: C:\Program Files\Bazaar\python25.dll 2.5.4
  Python standard library: C:\Program Files\Bazaar\lib\library.zip
  Platform: Windows-XP-5.1.2600-SP3
  bzrlib: C:\Program Files\Bazaar\lib\library.zip\bzrlib
  Bazaar configuration: C:\Documents and Settings\modul98\Application Data\bazaar\2.0
  Bazaar log file: C:\work\.bzr.log

Copyright 2005, 2006, 2007, 2008, 2009 Canonical Ltd.
http://bazaar-vcs.org/

bzr comes with ABSOLUTELY NO WARRANTY. bzr is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 2 or later.

Bazaar is part of the GNU Project to produce a free operating system.

I believe this is a side effect of Martin's change to display transfer info even when we don't have a progress bar. I think his rationale was reasonable, but it means we don't really have a sync point where we can say "and now clean up everything".

The other thing to do is to change 'self.outf.write()' at the end of the function into using

output = ui.ui_factory.make_output_stream(...)

(Though if there are no tags, does it still clear the progress bar?)

summary: - `bzr tags -d bzr://xxx` left the progress bar garbage on the screen
+ `bzr tags -d bzr://xxx` leaves progress bar garbage on the screen
Changed in bzr:
importance: Undecided → Low
status: New → Confirmed
Martin Pool (mbp) wrote :

No, self.outf already goes to a ui output stream.

What is needed here is that before exiting bzr, we should tell the ui factory to clear the line.

tags: added: progress
Martin Pool (mbp) on 2010-02-03
tags: added: easy
Martin Pool (mbp) on 2010-02-13
summary: - `bzr tags -d bzr://xxx` leaves progress bar garbage on the screen
+ progress bar is not removed when bzr exits
Changed in bzr:
importance: Low → Medium
Martin Packman (gz) wrote :

Neither roryy on IRC could reproduce this on trunk, so it's fixed? But we also couldn't see the problem on old revisions like tag:bzr-2.1.0rc2 either, so we're not sure what's going on.

Gary van der Merwe (garyvdm) wrote :

I was not able to reproduce this with tags -d, but was able to reproduce with launchpad-login.

This was fixed by rev 5310.

Changed in bzr:
assignee: nobody → Robert Collins (lifeless)
milestone: none → 2.2.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers