AuthenticationConfig.{get_password,get_username}() returns unicode or str objects

Bug #514301 reported by Jelmer Vernooij on 2010-01-29
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil

Bug Description

  affects bzr

AuthenticationConfig.get_password() returns a unicode string when
retrieving a password from authentication.conf, and a plain string when
prompting the user. It would be nice if it could consistently return an
object of either of these types.

Martin Pool (mbp) on 2010-02-15
tags: added: authentication config unicode
Changed in bzr:
status: New → Confirmed
importance: Undecided → Low
Vincent Ladeuil (vila) wrote :

It must be Unicode and respect user input encoding even.

Gordon Tyler (doxxx) wrote :

Changing this to High since it makes authenticated svn servers impossible to use (see bug 894695) unless the user encodes their username and password into the SVN URL on the command-line, which is NOT a good practice.

Changed in bzr:
importance: Low → High
Jelmer Vernooij (jelmer) on 2011-12-22
summary: - AuthenticationConfig.get_password() returns unicode or str objects
+ AuthenticationConfig.{get_password,get_username}() returns unicode or
+ str objects
Vincent Ladeuil (vila) on 2012-09-17
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2012-10-30
Changed in bzr:
milestone: none → 2.6b3
status: In Progress → Fix Released
Vincent Ladeuil (vila) on 2013-07-27
Changed in bzr:
milestone: 2.6b3 → 2.6.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers