bzr should inform me about changes to the format at branch time

Bug #512264 reported by Michael Bienia on 2010-01-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned

Bug Description

I was doing a packaging merge the UDD way:
 bzr init-repo fuse
 cd fuse
 bzr branch lp:ubuntu/fuse fuse-lucid
 (and so on)
After done with merging I wanted to push my branch to LP for reviewal:
 bzr push lp:~geser/ubuntu/lucid/fuse/merge

Using default stacking branch /~ubuntu-branches/ubuntu/lucid/fuse/lucid at lp-64843152:///~geser/ubuntu/lucid/fuse
bzr: ERROR: KnitPackRepository('lp-64843152:///~ubuntu-branches/ubuntu/lucid/fuse/lucid/.bzr/repository')
is not compatible with
CHKInventoryRepository('lp-64843152:///~geser/ubuntu/lucid/fuse/merge/.bzr/repository')
different serializers

bzr should inform me that it might have problems with pushing later due to different repository format *before* I start working on a branch. In the end I redid this whole merge by branching again (but now without a bzr init-repo) so it kept the repository format and I could push it to LP successfully.

The LP branch is "Packs 6 rich-root (uses btree indexes, requires bzr 1.9)" while my branch (with init-repo) was "Repository format 2a - rich roots, group compression and chk inventories".

Martin Pool (mbp) wrote :

I think this is a dupe

Changed in bzr:
status: New → Confirmed
tags: added: formatui udd
Changed in bzr:
importance: Undecided → Medium

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Michael Bienia wrote:
> bzr should inform me that it might have problems with pushing later due
> to different repository format *before* I start working on a branch.

These two branch formats are model-compatible-- that is, they are both
rich-root formats. So you could push revisions from your local merge
into lp:ubuntu/fuse.

stacking should just be smarter about these situations, and either
- - do an unstacked push
- - select the same target format as the stacking branch.

> In
> the end I redid this whole merge by branching again (but now without a
> bzr init-repo) so it kept the repository format and I could push it to
> LP successfully.

That's a shame-- you could have just branched locally and upgraded the
local copy to --2a.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAktndggACgkQ0F+nu1YWqI0ptACdFf3irvbP1eJZ1Zk5SGzIxp63
DJEAnAxGzOL33orBQEh+Spxg0USIsMcV
=Uigj
-----END PGP SIGNATURE-----

Michael Bienia (geser) wrote :

On 2010-02-02 00:47:09 -0000, Aaron Bentley wrote:
> These two branch formats are model-compatible-- that is, they are both
> rich-root formats. So you could push revisions from your local merge
> into lp:ubuntu/fuse.

I'm not a core-dev, so I can't upload the "fuse" package to the archive
and would be really surprised if I could push changes to the packaging
branch without upload permissions. Therefore I tried to push my local
branch to lp:~geser/ubuntu/lucid/fuse/merge and file a merge proposal to
request sponsoring.

> > In
> > the end I redid this whole merge by branching again (but now without a
> > bzr init-repo) so it kept the repository format and I could push it to
> > LP successfully.
>
> That's a shame-- you could have just branched locally and upgraded the
> local copy to --2a.

My local branch was in 2a format (bzr used it automatically because I
branched it inside an "init-repo" directory). I would have needed a
downgrade as far as I can tell.

Aaron Bentley (abentley) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Michael Bienia wrote:
> On 2010-02-02 00:47:09 -0000, Aaron Bentley wrote:
>> These two branch formats are model-compatible-- that is, they are both
>> rich-root formats. So you could push revisions from your local merge
>> into lp:ubuntu/fuse.
>
> I'm not a core-dev, so I can't upload the "fuse" package to the archive
> and would be really surprised if I could push changes to the packaging
> branch without upload permissions.

I wasn't trying to suggest that this was a good thing to do, just
explain the implications of being model-compatible.

>> That's a shame-- you could have just branched locally and upgraded the
>> local copy to --2a.
>
> My local branch was in 2a format (bzr used it automatically because I
> branched it inside an "init-repo" directory). I would have needed a
> downgrade as far as I can tell.

Oh, sorry if I misunderstood. You could just branched locally and
downgraded the local copy, then.

Aaron
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAktwPMwACgkQ0F+nu1YWqI3ifACgiG4E7q6tjjIgy68smhIcfvOX
PcoAnRjPg/S7aqf4kChTvXqACGEnhwGi
=wY4V
-----END PGP SIGNATURE-----

Robert Collins (lifeless) wrote :

We now print a message about format conversions, including the network name. This is perhaps not enough, but OTOH we're driving to have all the branches on LP upgraded anyway, so this should diminish in importance fairly quickly.

Changed in bzr:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers