Locks should be waitable for

Bug #49556 reported by Daniel Silverstone on 2006-06-13
2
Affects Status Importance Assigned to Milestone
Bazaar
Wishlist
John A Meinel

Bug Description

I have a lot of branches in a repository for development with launchpad and also a similar situation with some personal projects.

At times, I want to commit various bits on several branches and then push them all. It would be really nice if I could have a --wait-for-lock argument to bzr which causes the locking semantics to change from "complain when not acquirable" to "wait for a bit and try again" -- probably with some limits like not waiting for more than an hour for a lock.

This way I can start in one terminal, review my diff, commit, bzr push, then move on to the next terminal an d rinse/repeat.

Perhaps it could be something in bazaar.conf to save extra confusing commandline syntax?

Related branches

Changed in bzr:
importance: Untriaged → Wishlist
John A Meinel (jameinel) wrote :

The associated branch has a partial fix for this.
LockDir (which is our locking primative in new-format repositories) already had the ability to spin on a lock, it just wasn't used.

The associated branch enables that ability.
It defaults to waiting no more that 1 minute, and currently doesn't expose a wait to change this. Mostly because chain of command makes it tricky to figure out where to get the information, and how to pass it around.

Changed in bzr:
assignee: nobody → jameinel
status: Unconfirmed → Fix Committed
John A Meinel (jameinel) wrote :

merged into 0.12

Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers