bzr doesn't gracefully handle interrupted push/branch operations

Bug #45504 reported by John Dong on 2006-05-19
6
Affects Status Importance Assigned to Milestone
Bazaar
Medium
John A Meinel

Bug Description

If a keyboard interrupt, network/system failure, or any other event interrupts a branch or push operation, bzr is unable to resume or even gracefully re-initiate the previous operation. Instead, cryptic errors are presented to the user (no WorkingTree for interrupted branch, File Exists for push). Users have to remove .bzr by hand for bzr to function properly again.

This is terribly confusing to the novice user and annoying to the experienced user. Bzr should either

(a) Gracefully recover from interrupted actions, either by resuming from where it left off (preferable) or even cleaning out its previous attempt and starting from scratch

or (b) Recognize this situation and ask the user in an understandable message to remove .bzr

David Allouche (ddaa) wrote :

Is that a duplicate of bugj 53340?

David Allouche (ddaa) wrote :

I mean bug 53340.

David Allouche (ddaa) wrote :

or of bug 30576?

John A Meinel (jameinel) wrote :

The associated branch has a fix which creates the branch before populating it, which should allow resuming the transfer.

Changed in bzr:
assignee: nobody → jameinel
status: Unconfirmed → In Progress
status: In Progress → Fix Committed

On Thu, 2006-12-21 at 22:34 +0000, John A Meinel wrote:
> The associated branch has a fix which creates the branch before
> populating it, which should allow resuming the transfer.

I'm not sure this is a 'fix'. Surely just changing 'push' to create a
branch object if needed is simpler, and wont have the effect of having
an empty branch appear during the initial push.

--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

John A Meinel (jameinel) on 2007-02-07
Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers