test failure on babune: bzrlib.tests.per_transport.TransportTests.test_append_bytes(FTPTestServer

Bug #443041 reported by Vincent Ladeuil on 2009-10-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Vincent Ladeuil

Bug Description

======================================================================
FAIL: bzrlib.tests.per_transport.TransportTests.test_append_bytes(FTPTestServer) (subunit.RemotedTestCase)
----------------------------------------------------------------------
RemoteException: Traceback (most recent call last):
  File "/home/vila/buildbot/bzr/slaves/jaunty/tests/jaunty/build/bzrlib/tests/per_transport.py", line 736, in test_append_bytes
    t.append_bytes('a', 'add\nsome\nmore\ncontents\n'))
AssertionError: not equal:
a = 20
b = 0

======================================================================
FAIL: bzrlib.tests.per_transport.TransportTests.test_append_bytes(FTPTestServer) (subunit.RemotedTestCase)
----------------------------------------------------------------------
RemoteException: Traceback (most recent call last):
  File "/home/vila/buildbot/bzr/slaves/jaunty/tests/jaunty/build/bzrlib/tests/per_transport.py", line 736, in test_append_bytes
    t.append_bytes('a', 'add\nsome\nmore\ncontents\n'))
AssertionError: not equal:
a = 20
b = 0

Related branches

Vincent Ladeuil (vila) on 2009-10-05
Changed in bzr:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Vincent Ladeuil (vila)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Vincent Ladeuil wrote:
> Public bug reported:
>
> ======================================================================
> FAIL: bzrlib.tests.per_transport.TransportTests.test_append_bytes(FTPTestServer) (subunit.RemotedTestCase)
> ----------------------------------------------------------------------
> RemoteException: Traceback (most recent call last):
> File "/home/vila/buildbot/bzr/slaves/jaunty/tests/jaunty/build/bzrlib/tests/per_transport.py", line 736, in test_append_bytes
> t.append_bytes('a', 'add\nsome\nmore\ncontents\n'))
> AssertionError: not equal:
> a = 20
> b = 0
>
>
> ======================================================================
> FAIL: bzrlib.tests.per_transport.TransportTests.test_append_bytes(FTPTestServer) (subunit.RemotedTestCase)
> ----------------------------------------------------------------------
> RemoteException: Traceback (most recent call last):
> File "/home/vila/buildbot/bzr/slaves/jaunty/tests/jaunty/build/bzrlib/tests/per_transport.py", line 736, in test_append_bytes
> t.append_bytes('a', 'add\nsome\nmore\ncontents\n'))
> AssertionError: not equal:
> a = 20
> b = 0
>

This seems fairly serious, in that it would appear your FTP server is
saying it isn't actually appending the content we are passing it...

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkrKAYIACgkQJdeBCYSNAAOo8QCgtIE4XpZTUsjgwp9fJvs1aNQZ
eNsAoIfZnFmDhQq6Sulh9HEyUDGUoJ/I
=eWPD
-----END PGP SIGNATURE-----

Vincent Ladeuil (vila) on 2009-10-05
Changed in bzr:
status: Confirmed → Fix Committed
Vincent Ladeuil (vila) wrote :

As explained in the commit message, this was due to the GSSAPI ftp client which wasn't initialising
the mode correctly.
This seems to be triggered only by the test suite though.

Changed in bzr:
milestone: none → 2.1.0b1
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers