1.17 extensions are not compatible with python 2.4

Bug #399366 reported by John A Meinel on 2009-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Critical
John A Meinel

Bug Description

I went to build the 1.17 installers, but it seems that some of the extensions are not compatible with python2.4

bzrlib/_known_graph_pyx.c: In function `__pyx_f_6bzrlib_16_known_graph_pyx_10KnownGraph_heads':
bzrlib/_known_graph_pyx.c:941: warning: implicit declaration of function `PyFrozenSet_New'

It seems that "set" and "frozenset" existed in python2.4 but the C api was not exported. I'll work up a patch which changes the inner loop a bit. I'm hoping it isn't much slower.

John A Meinel (jameinel) on 2009-07-14
Changed in bzr:
status: In Progress → Fix Committed
Jonathan Lange (jml) wrote :

Given that this has landed in bzr.1.17 as r4529 can we mark this as Fix released.

John A Meinel (jameinel) on 2009-07-17
Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers