Packaging Bug: test SSL certificates missing from 1.16 PPA

Bug #392401 reported by Martitza on 2009-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Vincent Ladeuil

Bug Description

Vincent and Martin made significant contributions leading to this report.

See also: bug #392402 entitled "Selftest: attempt to HTTPS test server should time out and generate an error"

The following tests each contain multiple tests which hang, apparently because the ssl certiciates are missing from /usr/lib/python2.6/dist-packages/bzrlib/tests/ssl_certs as installed by the 1.16 PPA. Copying the certificates from the 1.16 tarball allows the tests to run.

test_read_bundle.TestReadBundleFromURL.test_read_fail(HTTPSServer_PyCurl)
test_read_bundle.TestReadBundleFromURL.test_read_mergeable_from_url(HTTPSServer_urllib)
test_read_bundle.TestReadBundleFromURL.test_read_mergeable_respects_possible_transports(HTTPSServer_urllib)

test_http.TestActivity.test_get(urllib,HTTP/1.0,https)
test_http.TestActivity.test_has(urllib,HTTP/1.0,https)
test_http.TestActivity.test_post(urllib,HTTP/1.0,https)
test_http.TestActivity.test_readv(urllib,HTTP/1.0,https)

test_transport_implementations.TransportTests.test_clone(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_connection_sharing(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_copy_to(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_get(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_has(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_readv(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_reuse_connection_for_various_paths(HTTPSServer_urllib)
test_transport_implementations.TransportTests.test_unicode_paths(HTTPSServer_urllib)

Related branches

Vincent Ladeuil (vila) wrote :

The root cause is that the https test server use some data files (certificates and keys) that are not installed by setup.py.
Under these conditions selftest can be run only from sources.
The test infrastructure is supposed to raise any exception occurring during server building *but* the exception
caused by a missing cert/key file is swallowed by the python SocketServer :-/

summary: - Packaging Bug: SSL certificates missing from 1.16 PPA
+ Packaging Bug: test SSL certificates missing from 1.16 PPA
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
importance: Undecided → Medium
status: New → Confirmed
description: updated
Vincent Ladeuil (vila) on 2009-07-10
description: updated
Vincent Ladeuil (vila) on 2009-08-14
Changed in bzr:
milestone: none → 2.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers