upgrade fails between dev formats

Bug #388727 reported by Matthew Fuller on 2009-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
Jelmer Vernooij

Bug Description

Creating a branch in any of {development[67]-rich-root,2a} and trying to upgrade it to a later one in the series fails with

bzr: ERROR: Cannot convert to format <RepositoryFormatCHK2>. Does not support nested trees

The same thing occurs trying to upgrade it to 1.9-rich-root.

Martin Pool (mbp) on 2009-06-17
Changed in bzr:
milestone: none → 1.16

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

fullermd wrote:
> Public bug reported:
>
> Creating a branch in any of {development[67]-rich-root,2a} and
> trying to upgrade it to a later one in the series fails with
>
> bzr: ERROR: Cannot convert to format <RepositoryFormatCHK2>. Does
> not support nested trees
>
> The same thing occurs trying to upgrade it to 1.9-rich-root.
I submitted a fix for this, but haven't gotten round to writing a test
for it yet:

http://bundlebuggy.aaronbentley.com/project/bzr/request/%3C20090605165828.GA4605%40vernstok.nl%3E

Cheers,

Jelmer
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iJwEAQECAAYFAko5hN8ACgkQDLQl4QYPZuU5ggP+IeEtQKTR7yUlkNvX1cN+31ps
L/J7dClFK8uD0aTYXZFLiU/g4fWN/ef4vsVRS1W23bNLVW0BJmNX27ZxcInUsVFl
y9s/IzqV9qCwfv9i1jPCij0T4RPv3dxUlx/Vg+elAMSyN4f5clvhduMWT8xAo4Qd
ktNV8ReMzDivJkqW648=
=IUML
-----END PGP SIGNATURE-----

I'm not sure this is critical for 1.16 because:
dev6->2a works
dev7->2a doesn't
and few people should have dev7 format repos

-Rob

Martin Pool (mbp) on 2009-06-18
Changed in bzr:
assignee: nobody → Jelmer Vernooij (jelmer)
Matthew Fuller (fullermd) wrote :

> I'm not sure this is critical for 1.16 because:
> dev6->2a works

% bzr info | head -1
Standalone tree (format: development6-rich-root)
% bzr upgrade --format=2a
[...]
bzr: ERROR: Cannot convert to format <RepositoryFormat2a>. Does not support nested trees

Robert Collins (lifeless) wrote :

On Thu, 2009-06-18 at 01:00 +0000, fullermd wrote:
> > I'm not sure this is critical for 1.16 because:
> > dev6->2a works
>
> % bzr info | head -1
> Standalone tree (format: development6-rich-root)
> % bzr upgrade --format=2a
> [...]
> bzr: ERROR: Cannot convert to format <RepositoryFormat2a>. Does not support nested trees

Oh, I thought that that had already been fixed.

There are two separate problems then; the nested tree flag check is
wrong (data changed, code not changed) *and* there is a bug in the
streaming-chk code path.

-Rob

Jonathan Lange (jml) wrote :

Submitting jelmer's patch to PQM for 1.16.

Vincent Ladeuil (vila) on 2009-08-26
Changed in bzr:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers