Merge cdiff into diff

Bug #376594 reported by Daniel Clemente on 2009-05-14
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Bazaar
Wishlist
Unassigned
Breezy
Wishlist
Jelmer Vernooij

Bug Description

Coloured diff is nicer than coloruless diff for many users, and it has the option to disable it if the user doesn't want it. Therefore coloured diff could be the default one, and be available into „bzr diff“ with no need for bzrtools.

A good colour combination must be chosen, considering there are many colour blind for red/green, and that the colors must look nice (i.e. not only grey on white).

The colored diff could have --color=auto as default instead of --color=always, so that „bzr diff > file.patch“ doesn't produce garbage. „bzr diff --color=always | less -r“ would be used if you want colors in less (just like the GNU program ls: „ls --color=always | less -r“).

Related branches

Jelmer Vernooij (jelmer) on 2009-05-28
Changed in bzr:
importance: Undecided → Wishlist
status: New → Triaged
Martin Pool (mbp) on 2010-03-19
Changed in bzr:
status: Triaged → Confirmed
Parth Malwankar (parthm) wrote :

Bug #597626 - bzrlib should support color, is related.

Robert Bruce Park (robru) wrote :

Is there a way to configure what colors are used? I appreciate the default choice of blue/red because of the propensity for red/green colorblindness, however I personally have a very difficult time reading blue text at all, so I really need red/green text to reduce eyestrain.

Jelmer Vernooij (jelmer) on 2017-11-09
tags: added: check-for-breezy
Jelmer Vernooij (jelmer) on 2019-10-20
tags: removed: check-for-breezy
Changed in brz:
status: New → Triaged
importance: Undecided → Wishlist
Jelmer Vernooij (jelmer) on 2019-10-26
Changed in brz:
status: Triaged → In Progress
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 3.1.0
tags: added: diff
Jelmer Vernooij (jelmer) on 2020-01-31
Changed in brz:
status: In Progress → Fix Committed
Jelmer Vernooij (jelmer) on 2020-06-08
Changed in brz:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers