CHK stream source doesn't handle ghosts.

Bug #376255 reported by Robert Collins on 2009-05-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Robert Collins
Launchpad itself
High
Michael Hudson-Doyle

Bug Description

bzr: ERROR: Revision {GHOST} not present in
"<bzrlib.groupcompress.GroupCompressVersionedFiles object at 0x>".

Related branches

 summary "smart server, new branch, ghosts, boom."

This isn't chk related.

summary: - smart server, CHK repo, ghosts, boom
+ smart server, new branch, ghosts, boom.
Robert Collins (lifeless) wrote :

On Wed, 2009-05-13 at 23:35 +0000, Robert Collins wrote:
> summary "smart server, new branch, ghosts, boom."
>
> This isn't chk related.

... or it may be. I'm going to keep this as 'generic' and once fixed see
if chk's have a unique further issue.

-Rob

tags: added: brisbane-core

Looks like lp's server needs upgraded, and this is purely CHK related. Debugging the chk aspects now.

description: updated
tags: added: lp-needs
summary: - smart server, new branch, ghosts, boom.
+ CHK stream source doesn't handle ghosts.
Robert Collins (lifeless) wrote :

This is needed to support branching from bbc formats when they have ghosts; e.g. bzr lp or pqm in bbc format.

Martin Pool (mbp) on 2009-05-14
Changed in bzr:
milestone: none → 2.0
Robert Collins (lifeless) wrote :

Revno 4362

Changed in bzr:
assignee: nobody → Robert Collins (lifeless)
milestone: 2.0 → none
status: Confirmed → Fix Released
John A Meinel (jameinel) wrote :

I'm not sure that this is a complete fix, but at least it fixes one part of the problem.

Changed in bzr:
milestone: none → 1.15rc1
Jonathan Lange (jml) wrote :

All this means is that Launchpad needs to upgrade to 1.15 this release cycle.

Changed in launchpad-code:
importance: Undecided → High
milestone: none → 2.2.5
status: New → Triaged
Paul Hummer (rockstar) on 2009-05-27
Changed in launchpad-code:
milestone: 2.2.5 → 2.2.6
John A Meinel (jameinel) wrote :

1.15 or 1.16 :)

Tim Penhey (thumper) on 2009-06-07
Changed in launchpad-code:
assignee: nobody → Michael Hudson (mwhudson)
status: Triaged → In Progress
Tim Penhey (thumper) on 2009-06-09
Changed in launchpad-code:
status: In Progress → Fix Committed
Jonathan Lange (jml) wrote :

This has landed, I think.

Changed in launchpad-code:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers