brisbane-core doesn't support stacking but should

Bug #373455 reported by Martin Pool on 2009-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
High
John A Meinel

Bug Description

As of now, the brisbane-core development-rich-root format doesn't support stacking; this should be fixed before the final release.

John reports that he did have the repository format supporting fallback_vfs, but it may need to be brought up to date with streaming fetch, and needs a check regarding filling in chk pages. Presumably we'd want whole inventories to be either present or not in each repository, and this needs to be specially coded.

Martin Pool (mbp) on 2009-05-07
Changed in bzr:
importance: Undecided → High
status: New → Confirmed
Martin Pool (mbp) on 2009-05-07
Changed in bzr:
assignee: nobody → John A Meinel (jameinel)
milestone: none → 1.16
tags: added: brisbane-core
John A Meinel (jameinel) wrote :

I might actually be able to get this into 1.15, as I think I have most of the work done.

I at least have all the *conceptual* requirements finished. I just need to do more direct testing to validate this. I'll associate the branch where I'm working.

Changed in bzr:
status: Confirmed → In Progress
John A Meinel (jameinel) wrote :

Submitting to PQM now.

Changed in bzr:
milestone: 1.16 → 1.15rc1
status: In Progress → Fix Released
John A Meinel (jameinel) wrote :

Turns out I need to resolve the recent changes to "_key_dependencies". Though I'll say that having the generic Repository object peek at self.revisions._index._key_dependencies seems like it has far more info than it should.

Changed in bzr:
status: Fix Released → Fix Committed
John A Meinel (jameinel) on 2009-06-01
Changed in bzr:
milestone: 1.15rc1 → 1.16
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers