RevisionNotPresent in insert_record_stream - bzr cannot branch from rocketfuel

Bug #372881 reported by Aaron Bentley
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Unassigned

Bug Description

Looks like a ghost handling problem in the smart server.

$ bzr branch -Derror bzr+ssh://bazaar.launchpad.net/~launchpad-pqm/launchpad/devel/ lp-from-scratch
bzr: ERROR: bzrlib.errors.RevisionNotPresent: Revision {[('Arch-1:<email address hidden>%launchpad--devel--0--patch-154',)]} not present in "KnitVersionedFiles(_KnitGraphIndex(CombinedGraphIndex()), <bzrlib.knit._DirectPackAccess object at 0x9f4d52c>)".

Traceback (most recent call last):
  File "/home/abentley/bzr/bzr.dev/bzrlib/commands.py", line 729, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/home/abentley/bzr/bzr.dev/bzrlib/commands.py", line 924, in run_bzr
    ret = run(*run_argv)
  File "/home/abentley/bzr/bzr.dev/bzrlib/commands.py", line 560, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/home/abentley/bzr/bzr.dev/bzrlib/builtins.py", line 1133, in run
    raise errors.BzrCommandError('Parent of "%s" does not exist.'
  File "/home/abentley/bzr/bzr.dev/bzrlib/bzrdir.py", line 1178, in sprout
    result_repo.fetch(source_repository, fetch_spec=fetch_spec)
  File "/home/abentley/bzr/bzr.dev/bzrlib/repository.py", line 1521, in fetch
    find_ghosts=find_ghosts, fetch_spec=fetch_spec)
  File "/home/abentley/bzr/bzr.dev/bzrlib/decorators.py", line 192, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/home/abentley/bzr/bzr.dev/bzrlib/repository.py", line 3085, in fetch
    pb=pb, find_ghosts=find_ghosts)
  File "/home/abentley/bzr/bzr.dev/bzrlib/fetch.py", line 82, in __init__
    self.__fetch()
  File "/home/abentley/bzr/bzr.dev/bzrlib/fetch.py", line 108, in __fetch
    self._fetch_everything_for_search(search)
  File "/home/abentley/bzr/bzr.dev/bzrlib/fetch.py", line 145, in _fetch_everything_for_search
    stream, from_format, resume_tokens)
  File "/home/abentley/bzr/bzr.dev/bzrlib/repository.py", line 3963, in insert_stream
    stacked repositories without looking for the missing basis parents
  File "/home/abentley/bzr/bzr.dev/bzrlib/repository.py", line 3997, in _locked_insert_stream
    # If serializers match and the target is a pack repository, set the
  File "/home/abentley/bzr/bzr.dev/bzrlib/knit.py", line 1548, in insert_record_stream
    raise RevisionNotPresent([record.key], self)
RevisionNotPresent: Revision {[('Arch-1:<email address hidden>%launchpad--devel--0--patch-154',)]} not present in "KnitVersionedFiles(_KnitGraphIndex(CombinedGraphIndex()), <bzrlib.knit._DirectPackAccess object at 0x9f4d52c>)".

Aaron Bentley (abentley)
Changed in bzr:
importance: Undecided → Critical
status: New → Confirmed
Revision history for this message
John A Meinel (jameinel) wrote :

Interesting....

I was seeing this with a --dev6 branch, but I thought it was just the new format.

And I'll mention that it breaks for *local* branching there, which means it would not be a Smart Server issue specifically.

Also, when I tested it, it was breaking while fetching 'revisions', so it wouldn't be caused by the new 'fill in parent inventories' logic.

I was talking about this on bug #336383

Aaron, can you confirm whether you can reproduce this branching locally into a standalone branch?

Revision history for this message
John A Meinel (jameinel) wrote :

I unmarked this as duplicate, because it has nothing to do with stacking, and bug #368418 is dealing with stacking issues.

Martin Pool (mbp)
summary: - bzr cannot branch from rocketfuel
+ RevisionNotPresent in insert_record_stream - bzr cannot branch from
+ rocketfuel
Revision history for this message
Robert Collins (lifeless) wrote :

What bzr version was this? If it was circa 1.13/1.14 please try to reproduce with 1.16.

Changed in bzr:
status: Confirmed → Incomplete
Revision history for this message
Andrew Bennetts (spiv) wrote :

FWIW, I can't reproduce this with the stable-2a branch of launchpad (which is in 2a format).

Revision history for this message
Robert Collins (lifeless) wrote : Re: [Bug 372881] Re: RevisionNotPresent in insert_record_stream - bzr cannot branch from rocketfuel

 status invalid

Changed in bzr:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers