annotate should include the working tree in the files being annotated

Bug #3439 reported by Robert Collins on 2005-10-21
2
Affects Status Importance Assigned to Milestone
Bazaar
Wishlist
Robert Collins

Bug Description

When I run 'annotate foo' and I have edited foo, I expect to see the version of foo in front ot me. I would expect to have to use 'annotate -r -1' to see the basis copy, or -r X to annotate an arbitrary revision.

Related branches

As I see it annotate is about looking at history, not working changes, but that could be just because that's the way annotate has always worked. I think we'd have to discuss this one on the list.

From a brief look at the code this won't be that easy, the annotation is tied directly to the weave, and AIUI we don't have a weave until we commit, so we'd have to fudge one up for the working tree?

Changed in bzr:
status: Unconfirmed → Confirmed
Robert Collins (lifeless) wrote :

This needs to be turned into a spec... hint, hint.

Martin Pool (mbp) wrote :

I agree, should be done.

Martin Pool (mbp) wrote :

This is now done in gannotate, though the display is not very obvious.

Martin Pool (mbp) wrote :

bug 202063 that the display is unobvious.

Changed in bzr:
assignee: nobody → lifeless
Changed in bzr:
milestone: none → 1.8
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers