pointless commit message now ugly

Bug #317357 reported by Robert Collins on 2009-01-15
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar
Low
Jonathan Riddell

Bug Description

$ bzr commit -m "trigger"
Committing to: ....
aborting commit write group: PointlessCommit(No changes to commit)
bzr: ERROR: no changes to commit. use --unchanged to commit anyhow

 affects bzr
--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

Related branches

Martin Pool (mbp) on 2009-01-15
Changed in bzr:
importance: Undecided → Low
status: New → Confirmed

On Thu, 2009-01-15 at 07:00 +0000, Martin Pool wrote:
> ** Changed in: bzr
> Importance: Undecided => Low
> Status: New => Confirmed

Are you sure this is low? Seems like something liable to cause lots of
user confusion - whats a write group, does the abort mean there is a
problem?
--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

Jojo (kuzniarpawel) wrote :

did you try to add a new file?

check first

bzr add

then

bzr commit -m "blah"

Daniel Clemente (n142857) wrote :

Jojo: yes, adding a file is needed, if you don't you get this error. This bug suggests precisely a better error message, something better than „aborting commit write group: PointlessCommit(No changes to commit)“.

Maybe:
ERROR: no changes to commit. Please add the files to commit (with --add) or use --unchanged to force an empty commit

A few days ago I could commit branches when just a few lines or something "minor" changed.
Today bzr keeps telling me that there where no changes even if a add a few lines of code to a file.

barabbas@kassandra:~/pyjama$ bzr commit -m "* some new fields for potato"
Committing to: /home/barabbas/Programming/python/pyjama/pyjama/
aborting commit write group: PointlessCommit(No changes to commit)
bzr: ERROR: no changes to commit. use --unchanged to commit anyhow

Do I HAVE to run "bzr --unchanged" all the time when I did not add new files?

Greetings

Vincent Ladeuil (vila) wrote :

@Daniel: If you modified a versioned file, bzr should not output that message.
Try issuing 'bzr st', you may be modifiying a file that is not (yet) versioned and
for which you need to issue 'bzr add <file>' first.

Sorry, this war really my fault (pre-coffee).

Thanks for your reply.

Jelmer Vernooij (jelmer) on 2011-02-02
tags: added: commit ui
tags: added: easy
Changed in bzr:
assignee: nobody → Federico Culloca (djthrottle)
status: Confirmed → In Progress
Jelmer Vernooij (jelmer) wrote :

Is this actually fixed?

Changed in bzr:
status: In Progress → Fix Released
milestone: none → 2.4b2
status: Fix Released → In Progress
milestone: 2.4b2 → none

I submitted a patch, I've been told it would get some correction and will be merged.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/20/2011 06:23 PM, Federico Culloca wrote:
> I submitted a patch, I've been told it would get some correction and
> will be merged.
>
Frederico's patch doesn't solve the original source of this bug, though
it does make things a little bit better.

The "ugly" part is that we now show an "abort commit" line, which we
would like to remove. It is a bit deeper. So we're certainly happy with
what Federico has done, but we should put this bug back to "Confirmed"
for now.

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk2vLAEACgkQJdeBCYSNAAMrkgCgh0/Z8rRpeJs6c1M4aazaFEwb
fHkAn2sBcd8jj+sUf55VpD0Z3JV9snwC
=lm8j
-----END PGP SIGNATURE-----

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/20/2011 06:23 PM, Federico Culloca wrote:
> I submitted a patch, I've been told it would get some correction and
> will be merged.
>

And I should mention, that you patch *has* been merged.
https://code.launchpad.net/~djthrottle/bzr/bug317357/+merge/56605

It will be part of the next 2.4 release (2.4b2)

John
=:->
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk2vLE8ACgkQJdeBCYSNAANGNQCeOOM10bNd901DUcgu2ry51GMi
NGAAoI2thGOblSxbq8RJUKxp3SVdlkwq
=QIc3
-----END PGP SIGNATURE-----

Jelmer Vernooij (jelmer) wrote :

On Wed, 2011-04-20 at 18:56 +0000, John A Meinel wrote:
> On 04/20/2011 06:23 PM, Federico Culloca wrote:
> > I submitted a patch, I've been told it would get some correction and
> > will be merged.
> >
>
> And I should mention, that you patch *has* been merged.
> https://code.launchpad.net/~djthrottle/bzr/bug317357/+merge/56605
>
> It will be part of the next 2.4 release (2.4b2)
The patch only changed an existing error message, it didn't hide the
"aborted commit group" message that IIRC was one of the reasons for the
bug. Did I miss something?

Cheers,

Jelmer

John A Meinel (jameinel) wrote :

Unmarking In Progress. Federico certainly improved the error message, but we still have the line:
aborting commit write group: PointlessCommit(No changes to commit)

Which is what this bug is about. We want to remove that line entirely, though it is happening at a low-level that makes it slightly tricky to do cleanly.

Changed in bzr:
assignee: Federico Culloca (djthrottle) → nobody
status: In Progress → Confirmed
Vincent Ladeuil (vila) on 2011-05-26
Changed in bzr:
milestone: none → 2.4b3
status: Confirmed → Fix Released
Martin Packman (gz) on 2011-05-26
Changed in bzr:
assignee: nobody → Jonathan Riddell (jr)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers