--stacked-on option doesn't resolve lp: urls

Bug #296592 reported by Martin Pool on 2008-11-11
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
Breezy
Medium
Jelmer Vernooij

Bug Description

bzr branch --stacked-on lp:bzr ........

eventually fails, showing that it tried to interpret lp:bzr as a relative path.

mbp@lithe% bzr push --stacked-on lp:bzr lp:~mbp/bzr/branchbuilder
Setting ssh/sftp usernames for launchpad.net.
Source format does not support stacking, using format: '1.6'
  Packs 5 (adds stacking support, requires bzr 1.6)

bzr: ERROR: Not a branch: "/home/mbp/bzr/branchbuilder/lp:bzr/".
zsh: exit 3 bzr push --stacked-on lp:bzr lp:~mbp/bzr/branchbuilder

Related branches

Jonathan Lange (jml) wrote :

Note that it should resolve the URL to its http expansion.

Changed in bzr:
importance: Undecided → Medium
status: New → Triaged
Jonathan Lange (jml) on 2010-03-03
tags: added: lp-directory
Jonathan Lange (jml) on 2010-03-03
tags: added: lpurl
removed: lp-directory
Martin Pool (mbp) on 2010-03-18
Changed in bzr:
status: Triaged → Confirmed
Jelmer Vernooij (jelmer) on 2011-03-16
tags: added: affects-linaro
Jelmer Vernooij (jelmer) wrote :

The issue is that in cmd_push() we call urlutils.normalize_url() on the stacked_on location, and:

charis:~/src/bzr/bzr.dev% python
Python 2.7.1+ (r271:86832, Dec 29 2010, 18:33:35)
[GCC 4.5.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from bzrlib import urlutils
>>> urlutils.normalize_url("lp:bzr")
'lp:bzrlp:bzr'

Jelmer Vernooij (jelmer) on 2017-11-08
tags: added: check-for-breezy
Jelmer Vernooij (jelmer) on 2019-02-16
tags: removed: check-for-breezy
Changed in brz:
status: New → Triaged
Jelmer Vernooij (jelmer) on 2019-02-16
Changed in brz:
importance: Undecided → Medium
assignee: nobody → Jelmer Vernooij (jelmer)
status: Triaged → In Progress
Jelmer Vernooij (jelmer) on 2019-06-02
Changed in brz:
status: In Progress → Fix Released
milestone: none → 3.0.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers