branch --delete subcommand

Bug #276295 reported by Jelmer Vernooij on 2008-09-30
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar
Wishlist
Jelmer Vernooij

Bug Description

It would be nice if "bzr branch" could have a --delete option, since branches don't necessarily have to be on the file system (e.g. GIT-style branches, branches in a remove svn repository).

Related branches

John A Meinel (jameinel) wrote :

I don't think this belongs on the 'bzr branch' command. I believe it is there for "git branch" but the general flow of that command is very different from bzr's command. I'm not opposed to having some sort of "delete my branch" but I don't think it fits 'bzr branch' very well.

Changed in bzr:
importance: Undecided → Wishlist
status: New → Triaged
Jelmer Vernooij (jelmer) wrote :

It would be nice to be consistent with "bzr tag", which also has --delete

Jelmer Vernooij (jelmer) wrote :

I think John and I agree that it would be nice to have such a command, but disagree where it should be. John, if not, please speak up :-)

John A Meinel (jameinel) wrote :

Sounds right. I think having the command is good, having it hang of from "branch" isn't really the right location. If anything, *I* would put it under "bzr reconfigure --delete-branch".

I realize that there exists "bzr tag --delete" but I personally feel that "bzr tag" is about *managing* tags far more than "bzr branch" is about *managing* branches. "bzr branch" is about one aspect, which is only *creating* a new one. I'm willing to be persuaded, but if we are adding delete, we should add some sort of rename/move, and we should consider if that fits the command. If we feel it does, then we can put them all in there.

Jelmer Vernooij (jelmer) on 2010-01-28
Changed in bzr:
assignee: nobody → Jelmer Vernooij (jelmer)

Perhaps we need to go to rmbranch, rmtag, etc commands in general.
--
Martin <http://launchpad.net/~mbp/>

Martin Pool (mbp) on 2010-03-19
Changed in bzr:
status: Triaged → Confirmed
John A Meinel (jameinel) wrote :

rmbranch exists, so this is fixed.

Changed in bzr:
milestone: none → 2.2.0
status: Confirmed → Fix Released
Frits Jalvingh (fjalvingh) wrote :

bzr rmbranch does not delete the branch. It leaves:
/home/jal/puzzler-bzr/vp-t-p2053-bvm/
/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr
/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr/branch-format
/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr/branch-lock
/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr/README

Jelmer Vernooij (jelmer) wrote :

Those files are (oddly enough) not a part of the branch but a part of the control directory, which 'bzr rmbranch' does not remove. It does remove the branch part of a control directory (which usually lives in .bzr/branch).

Cheers, jelmer

Frits Jalvingh <email address hidden> wrote:

>bzr rmbranch does not delete the branch. It leaves:
>/home/jal/puzzler-bzr/vp-t-p2053-bvm/
>/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr
>/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr/branch-format
>/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr/branch-lock
>/home/jal/puzzler-bzr/vp-t-p2053-bvm/.bzr/README
>
>--
>You received this bug notification because you are subscribed to the
>bug
>report.
>https://bugs.launchpad.net/bugs/276295
>
>Title:
> branch --delete subcommand
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/bzr/+bug/276295/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions