serve --quiet is not quiet

Bug #252834 reported by RLVJ on 2008-07-29
4
Affects Status Importance Assigned to Milestone
Bazaar
Low
Gordon Tyler

Bug Description

Bug:
Since --quiet is likely to be used in serving, it must in some scenarios be absolutely silent.
It may have it's stdout and sterr file descriptors closed before being exec()ed.

If bzr serve runs in a separate process, it should close it's own stdout and stderr; in any case, it should completely avoid output when called with --quiet.

Strict silence might not be as important for other commands (branch, pull, ...).

Perhaps quiet or another option should be a command, which after being executed will silence the bzr instance for all commands until verbosity is reactivated.

Related branches

James Westby (james-w) wrote :

Hi,

Do you see anything else than the "listening on port: " message?

Thanks,

James

Changed in bzr:
importance: Undecided → Low
status: New → Confirmed
RLVJ (nathan-johnson) wrote :

The only message I see is: "listening on port: ".

description: updated
RLVJ (nathan-johnson) wrote :

In BASh, all default file descriptors can be closed by
0<&- 1<&- 2<&- bzr serve --quiet
which causes bzr to quit.
Only closing stdout & stderr, as in
1<&- 2<&- bzr serve --quiet
does not cause bzr to quit.

Gordon Tyler (doxxx) wrote :

Cannot reproduce in 2.1.0b3. "bzr serve -q" produces no output to the console.

Gordon Tyler (doxxx) wrote :

I'm going to write a test case for this.

Changed in bzr:
assignee: nobody → Gordon Tyler (doxxx)
Gordon Tyler (doxxx) on 2009-11-20
Changed in bzr:
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2009-11-27
Changed in bzr:
status: In Progress → Fix Committed
Vincent Ladeuil (vila) on 2009-12-01
Changed in bzr:
status: Fix Committed → Fix Released
milestone: none → 2.1.0b4
status: Fix Released → Fix Committed
John A Meinel (jameinel) on 2009-12-14
Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers