Better document init-repo, specially --no-trees

Bug #248182 reported by Daniel Clemente on 2008-07-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Neil Martinsen-Burrell

Bug Description

„bzr help init-repo“ shows:

---
Options:
  --no-trees Branches in the repository will default to not having
                        a working tree.
----

  This is a short and concise description.
  Then at the end it says:

---
Description:
  New branches created under the repository directory will store their
  revisions in the repository, not in the branch directory.

  If the --no-trees option is used then the branches in the repository
  will not have working trees by default.
---

   The second sentence adds nothing (it's the same as in the first snippet). Further explanation is needed, because a new user probably doesn't know:
- what exactly will be omited: just the tracked files, or the .bzr directory, or both, or something else... („Working tree“ has to be precised)
- what does it help for. Is it desirable? Is it necessary for something? In which scenario is it useful?

   The first sentence also lacks:
- what does „init-repo“ achieve (for instance: „Information common to all branches will thus be shared and will take less space. Otherwise, the same data would be repeated in each branch“

  The user can be directed to the manual to learn the details, but in my opinion the basic information should be in the help, so that new users can grasp if the command suits their needs.

Related branches

James Westby (james-w) on 2008-07-14
Changed in bzr:
importance: Undecided → Medium
status: New → Confirmed
John O'Brien (jdobrien) wrote :

I stumbled upon this while trying to make sure --no-trees was the option for me...

+1

Changed in bzr:
assignee: nobody → daniel-thewatkins
Samuel Bronson (naesten) on 2009-07-25
Changed in bzr:
assignee: Daniel Watkins (daniel-thewatkins) → Samuel Bronson (naesten)
Changed in bzr:
assignee: Samuel Bronson (naesten) → Neil Martinsen-Burrell (nmb)
milestone: none → 2.1.0b4
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers